On Do, 2011-05-12 at 13:42 +0100, Christophe Dumez wrote:
> ---
> 0001: QContactEBook constructor: code clean up
> ---
> 0002: QContactLocalId UID2QContactLocalId: Refactor function
> 
> Use regular expression to efficiently and more safely validate
> the input uid. Remove useless check in conversion since toUid()
> method already returns 0 when the conversion fails.

Somehow "efficiently" doesn't necessarily go together with "regular
expressions" for me, but I agree that it is safer and more readable.
Merged.

> ---
> 0003: Contact callbacks: Remove useless NULL pointer check
> 
> Replace the user data NULL pointer check by an ASSERT
> to that there is no check in release mode. This
> should not happen unless there is a bug anyway.
> ---
> 0004: QContactEBookEngine::synthesizedDisplayLabel: Rewrite method
> 
> Rewrite the method so that it does not try to fetch the display
> label from the database. It did not work and it is not supported
> to try anyway (according to the doc).
> 
> Remove the QContactEBook::getDisplayName() method that is no
> longer used.
> 
> Improved synthesizedDisplayLabel() so that it uses the
> organization name if available.
> ---
> 0005:  QContactEBook::QContactLocalId2UID() Rewrite method
> 
> Rewrite the method to make it simpler and probably more efficient.
> Stop using QString::sprintf() as advised by the documentation and
> replace it with QString::arg().
> ---
> 0006: Contacts callbacks: avoid code duplication
> ---
> 0007: QContactFetchByIdRequestWorker: Correctly report NoError code
> ---
> 0008: Engine: Make sure the ManagerURI is set for fetched contacts
> 
> The managerUri was not set for fetched contacts. Also update
> the unit tests so that to check this.
> ---
> 0009: QContactEBook::setSelfContactId() Slight assignment optimization
> ---
> 0010: QContactEBook::getEContact() Rewrite method
> 
> Rewrite method to avoid code duplication and improve
> error reporting.
> ---
> 0011: QContactEBook::setDetailValues() Remove method prototype
> 
> This method is not defined and not used anywhere.
> ---
> 0012: Project: header includes clean up
> 
> Remove useless header includes.
> ---
> 0013: QContactEBookBackend: Move QContactEBookEngineData to cpp file
> 
> There is no point exposing this private engine data to other
> classes.
> ---
> 0014: Project: Project files clean up
> 
> Restructure project files to avoid configuration
> duplication.

Merged.

> ---
> 0015: Engine: Rename engine folder for src to engine

I skipped that in favor of the cleaned up version of that patch.

-- 
Best Regards, Patrick Ohly

The content of this message is my personal opinion only and although
I am an employee of Intel, the statements I make here in no way
represent Intel's position on the issue, nor am I authorized to speak
on behalf of Intel on this matter.


_______________________________________________
MeeGo-dev mailing list
MeeGo-dev@meego.com
http://lists.meego.com/listinfo/meego-dev
http://wiki.meego.com/Mailing_list_guidelines

Reply via email to