Let me explain it differently.

Using the Winbox created a system script with these commands:

:log info "Starting Backup Script..."
:global backupfiletext ([/system identity get name])
/file rem $backupfiletext
:delay 2s
/export file=$backupfiletext
:log info "Waiting 5s for backup to complete..."
:delay 5s
:log info "Backup being emailed..."
/tool e-mail send to="yath...@imaginenetworksllc.com" subject=([/system
identity get name] . " Backup")
from=mtback...@imaginenetworksllc.comfile=$backupfiletext
body=[/system identity get name] server=4.2.2.2
:log info "Finished Backup Script!"

Now type /sys script export

Now copy/paste the output from/to the same prompt

Watch it error out (probably invalid argument name)

There doesn't look to be anything unique, but even if there were it should
not cause an issue importing it to the same MikroTik from which it was
exported!

Josh Luthman
Office: 937-552-2340
Direct: 937-552-2343
1100 Wayne St
Suite 1337
Troy, OH 45373

"When you have eliminated the impossible, that which remains, however
improbable, must be the truth."
--- Sir Arthur Conan Doyle


On Wed, Jul 15, 2009 at 3:32 AM, Hilton Ralphs <hil...@think.co.za> wrote:

> Firstly the order of items in an export is not ideal for an import.
>
> You have to juggle sections around in a logical orderl pretend you are
> actually typing the commands.
>
> So effectively you need to remove all references to MAC addresses as this
> buggers things up. Import the interface section first.
>
> Hope this helps.
>
> --
> Regards
> Hilton J Ralphs
> Think Technologies
>
> -----Original Message-----
> From: Josh Luthman
>
> Has anyone tried importing a system script before?
>
>
>
>
> _______________________________________________
> Mikrotik mailing list
> Mikrotik@mail.butchevans.com
> http://www.butchevans.com/mailman/listinfo/mikrotik
>
> Visit http://blog.butchevans.com/ for tutorials related to Mikrotik
> RouterOS
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: 
<http://www.butchevans.com/pipermail/mikrotik/attachments/20090715/53c432fb/attachment.html>
_______________________________________________
Mikrotik mailing list
Mikrotik@mail.butchevans.com
http://www.butchevans.com/mailman/listinfo/mikrotik

Visit http://blog.butchevans.com/ for tutorials related to Mikrotik RouterOS

Reply via email to