or you can do tis:

/ routing filter

add action=accept chain=isp1-out prefix=192.168.48.0/20
add action=accept chain=isp1-out prefix=192.168.50.0/23 set-bgp-prepend=5
add action=accept chain=isp1-out prefix=192.168.52.0/23 set-bgp-prepend=5
add action=discard chain=isp1-out prefix=0.0.0.0/0 prefix-lenght=0-32


On 27/12/2013 19:45, Keith Barber wrote:
Those will only announce just those 3 subnets.
If you have smaller subnets that you're advertising, you can use the 
'prefix-length' field.

Adjust the length depending on how large or small your advertisements are.


/routing filter
add action=accept chain=isp1-out prefix=192.168.50.0/23 set-bgp-prepend=5
add action=accept chain=isp1-out prefix=192.168.52.0/23 set-bgp-prepend=5
add action=accept chain=isp1-out prefix=192.168.48.0/20 prefix-length=20-23
add chain=isp1-out action=discard

-Keith-



----- Original Message -----
From: "Terri Kelley" <net...@farm-market.net>
To: "Mikrotik discussions" <Mikrotik@mail.butchevans.com>
Sent: Friday, December 27, 2013 5:25:12 PM
Subject: [Mikrotik] bgp prepend

Been too long since I've done any of this and haven't in RouterOS. I'm wanting 
to load balance incoming traffic to my bgp edge from two fiber connections. So 
my thought was to prepend the subnets of my /20 that I want to come in from the 
other upstream, say ISP2. ISP1 is always heavier use. Seems in cisco that you 
could advertise the whole /20 and then just put the couple of prepended subnets 
that you wanted rather than having to break down all of it. Is that correct? If 
that is the case it would look something like this in RouterOS…

/routing filter
add action=accept chain=isp1-out prefix=192.168.48.0/20
add action=accept chain=isp1-out prefix=192.168.50.0/23 set-bgp-prepend=5
add action=accept chain=isp1-out prefix=192.168.52.0/23 set-bgp-prepend=5
add chain=isp1-out action=discard
add action=accept chain=isp2-out prefix=192.168.48.0/20
add chain=isp2-out discard

That should put the 50.0/23 and 52.0/23 over on isp2 and allow everything else 
to choose which side. Or do I have to list all of the subnets prepended and not?

Terri Kelley
Network Engineer
254-697-6710
Farm to Market Broadband



-------------- next part --------------
An HTML attachment was scrubbed...
URL: 
<http://mail.butchevans.com/pipermail/mikrotik/attachments/20131227/b9084a4b/attachment.html>
_______________________________________________
Mikrotik mailing list
Mikrotik@mail.butchevans.com
http://mail.butchevans.com/mailman/listinfo/mikrotik

Visit http://blog.butchevans.com/ for tutorials related to Mikrotik RouterOS
_______________________________________________
Mikrotik mailing list
Mikrotik@mail.butchevans.com
http://mail.butchevans.com/mailman/listinfo/mikrotik

Visit http://blog.butchevans.com/ for tutorials related to Mikrotik RouterOS


--
Sds.

Alexandre Jeronimo Correa
Sócio-Administrador

Office: +55 34 3351 3077

Onda Internet
www.onda.net.br

_______________________________________________
Mikrotik mailing list
Mikrotik@mail.butchevans.com
http://mail.butchevans.com/mailman/listinfo/mikrotik

Visit http://blog.butchevans.com/ for tutorials related to Mikrotik RouterOS

Reply via email to