Greetings,

Requirements:

Group-A Users - 10.10.0.1/24

Group-A Users Bandwidth Allowed = 64k Per User with following Priorities
ICMP = Priority 1
HTTP = Priority 2
All Other Traffic = Priority 3

(Means per user should get 64k, but ICMP should get 1st priority from this 64k, 
http second, and other traffic 3rd).

PROBLEM:
With following rules, I have to allow separate bandwidth fro each packets, like 
icmp 64k, http 64, other traffic 64k, which becomes 192k per user.

Can some one please correct me what i am doing wrong here?

Code: 
Select all
/ip firewall mangle
add action=mark-connection chain=forward comment="Group A - Mark HTTP Port 80" 
dst-port=80 new-connection-mark=Group_A_80_conn protocol=tcp 
src-address=10.10.0.0/24
add action=mark-packet chain=forward connection-mark=Group_A_80_conn 
new-packet-mark=Group_A_80_pkts passthrough=no
add action=mark-connection chain=forward comment="Group A - ICMP " 
new-connection-mark=Group_A_icmp-conn protocol=icmp src-address=10.10.0.0/24
add action=mark-packet chain=forward connection-mark=Group_A_icmp-conn 
new-packet-mark=Group_A_icmp-pkt passthrough=no
add action=mark-connection chain=prerouting comment="Group A - no mark CONN" 
connection-mark=no-mark new-connection-mark=GROUP-A-No_Mark_conn 
src-address=10.10.0.0/24
add action=mark-packet chain=prerouting connection-mark=GROUP-A-No_Mark_conn 
new-packet-mark=Group-A-No_Mark_Pkts passthrough=no

/queue type
add kind=pcq name=64k-download pcq-classifier=dst-address 
pcq-dst-address6-mask=64 pcq-rate=65536 pcq-src-address6-mask=64

/queue tree
add name="Group A - Global" parent=global queue=default
add name="PRIO 1 - ICMP" packet-mark=Group_A_icmp-pkt parent="Group A - Global" 
priority=1 queue=64k-download
add name="PRIO 2 - HTTP" packet-mark=Group_A_80_pkts parent="Group A - Global" 
priority=2 queue=64k-download
add name="PRIO 3 - All Other Traffic" packet-mark=Group-A-No_Mark_Pkts 
parent="Group A - Global" priority=3 queue=64k-download


Regards,
                                          
-------------- next part --------------
An HTML attachment was scrubbed...
URL: 
<http://mail.butchevans.com/pipermail/mikrotik/attachments/20160303/8cf7f202/attachment.html>
_______________________________________________
Mikrotik mailing list
Mikrotik@mail.butchevans.com
http://mail.butchevans.com/mailman/listinfo/mikrotik

Visit http://blog.butchevans.com/ for tutorials related to Mikrotik RouterOS

Reply via email to