On Wednesday 01 July 2026 17:25:19 LIU Hao wrote:
> 在 2026-6-28 22:16, Pali Rohár 写道:
> > Move common code from __p__osplatform.c and __p__osplatform_emul.c into
> > new helper function get_osplatform_helper which deduplicate code.
> > 
> > Do not treat zero value in _osplatform as uninitialized value as it is a
> > valid platform id value. Use additional variable for checking whether
> > _osplatform is initialized or not.
> > 
> > When function GetVersionExA on non-i386 systems fails then return
> > value 2 (WinNT) which is better default than the value 0 (Win32s) as
> > Win32s is i386-only.
> > 
> > On i386 builds use GetVersion function as GetVersionExA is not available on
> > older Windows NT systems.
> > ---
> >   mingw-w64-crt/misc/__p__osplatform.c      | 16 +++---
> >   mingw-w64-crt/misc/__p__osplatform_emul.c | 59 +++++++++++++++++++++--
> >   2 files changed, 62 insertions(+), 13 deletions(-)
> > 
> 
> The changes in code look good; however there are many many grammatical
> errors in comments, so I have pushed this one with this change:

Thank you for fixing grammatical errors.


_______________________________________________
Mingw-w64-public mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/mingw-w64-public

Reply via email to