Hi

Before I loose another night on this, I'd like to know. Does OpenBSD
4.1-stable supports per VLAN RSTP ?

It doesn't have to be Cisco's SSTP. All I want to achieve is to get
"discarding role alternate". When I use physical interfaces in bridge
it works. When I replace one physical int with a vlan it stops
working.

This is bridge between two openbsd boxes.

Can anyone point me to the right direction ?


sis1 - Connected to stupid unmanaged switch
sis5 , Connected to cisco switch
vlan4 = vlan 301


pirx2:~ # brconfig bridge0
bridge0: flags=41<UP,RUNNING>
       priority 40960 hellotime 2 fwddelay 4 maxage 6 holdcnt 6 proto rstp
       designated: id 00:00:24:c7:49:90 priority 36864
       sis5 flags=eb<LEARNING,DISCOVER,STP,AUTOEDGE,PTP,AUTOPTP>
               port 6 ifpriority 128 ifcost 200000 discarding role alternate
       sis1 flags=eb<LEARNING,DISCOVER,STP,AUTOEDGE,PTP,AUTOPTP>
               port 2 ifpriority 128 ifcost 200000 forwarding role root
       Addresses (max cache: 100, timeout: 240):
pirx2:~ # brconfig bridge0 down
pirx2:~ # brconfig bridge0 del sis5
pirx2:~ # brconfig bridge0 add vlan4 stp vlan4
pirx2:~ # brconfig bridge0 flushall
pirx2:~ # brconfig bridge0
bridge0: flags=0<>
       priority 40960 hellotime 2 fwddelay 4 maxage 6 holdcnt 6 proto rstp
       designated: id 00:00:24:c7:49:90 priority 36864
       vlan4 flags=eb<LEARNING,DISCOVER,STP,AUTOEDGE,PTP,AUTOPTP>
               port 14 ifpriority 128 ifcost 200000 discarding role designated
       sis1 flags=eb<LEARNING,DISCOVER,STP,AUTOEDGE,PTP,AUTOPTP>
               port 2 ifpriority 128 ifcost 200000 forwarding role root
       Addresses (max cache: 100, timeout: 240):
pirx2:~ # brconfig bridge0 up
pirx2:~ # brconfig bridge0
bridge0: flags=41<UP,RUNNING>
       priority 40960 hellotime 2 fwddelay 4 maxage 6 holdcnt 6 proto rstp
       designated: id 00:00:24:c7:49:90 priority 36864
       vlan4 flags=eb<LEARNING,DISCOVER,STP,AUTOEDGE,PTP,AUTOPTP>
               port 14 ifpriority 128 ifcost 200000 forwarding role designated
       sis1 flags=eb<LEARNING,DISCOVER,STP,AUTOEDGE,PTP,AUTOPTP>
               port 2 ifpriority 128 ifcost 200000 forwarding role root
       Addresses (max cache: 100, timeout: 240):
               00:1a:6c:48:4b:92 vlan4 1 flags=0<>

Important parts from cisco config
-----------------
Current configuration : 3933 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
no spanning-tree vlan 301
spanning-tree vlan 301 hello-time 1
spanning-tree vlan 301 forward-time 4
spanning-tree vlan 301 max-age 6
!
vlan internal allocation policy ascending
!
interface GigabitEthernet1/0/6
description Connected to pirx2 sis5
switchport access vlan 301
switchport mode access
no cdp enable
spanning-tree portfast
!
interface GigabitEthernet1/0/18
description Connected to pirx2 sis3 - vlan4
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 300-302
switchport mode trunk
no cdp enable
!
interface GigabitEthernet1/0/23
description Connected to AP radio
switchport access vlan 301
switchport mode access
shutdown
spanning-tree portfast
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan10
ip address 10.0.0.95 255.255.255.0
no ip route-cache
!
interface Vlan301
no ip address
no ip route-cache
!
ip classless
ip http server
ip http secure-server
!
control-plane
!
mac-address-table aging-time 10 vlan 301
end

--
Regards
Piotrek Kapczuk

Reply via email to