Hi,

I have a BGP and OSPF network. Configuration:
BSD A - ospf - net_1 - ospf - cisco1 - ospf - BSD B - ospf - cisco2 - ospf - net_2 - bgp - BSD C

In B, there are route that use net_1 which metric is bigger than net_2.
net_1 and net_2 are different provider.
Can anyone help me to figure out what happen? I don't have this problem when
C is also using OSPF. The network_2 have to change to other type of modem,
where those network are using mtu 16xx. So we need to configure BGP. My
network card in OpenBSD box do not support mtu setup.

# ospfctl show rib |grep 192.168.x.y
192.168.x.y/32 172.16.20.146 Type 1 ext Network 1723 00:00:01
I remove the host from A, and do ospfctl reload
# ospfctl show rib |grep 192.168.x.y
192.168.x.y/32 172.16.20.145 Type 2 ext Network 1572 00:00:32
I add the host back to A, and do ospfctl reload
# ospfctl show rib |grep 192.168.x.y
192.168.x.y/32 172.16.20.146 Type 1 ext Network 1723 00:00:01

My C bgpd.conf
AS 65227
router-id 172.16.20.10
network 172.16.10.0/27
network 192.168.x.y/32

# neighbors and peers
neighbor 172.16.20.9 {
      remote-as       17974
      descr           upstream
}

# filter out prefixes longer than 24 or shorter than 8 bits
#deny from any
#allow from any inet prefixlen 8 - 24

# do not accept a default route
deny from any prefix 0.0.0.0/0

# filter bogus networks
#deny from any prefix 10.0.0.0/8 prefixlen >= 8
#deny from any prefix 172.16.0.0/12 prefixlen >= 12
#deny from any prefix 192.168.0.0/16 prefixlen >= 16
deny from any prefix 169.254.0.0/16 prefixlen >= 16
deny from any prefix 192.0.2.0/24 prefixlen >= 24
deny from any prefix 224.0.0.0/4 prefixlen >= 4
deny from any prefix 240.0.0.0/4 prefixlen >= 4

----
My B ospfd.conf
router-id 172.16.20.149
redistribute 172.16.10.128/27

router-priority 0

area 0.0.0.2 {
      interface re3 {
      }
}

----
cisco1 configuration
interface FastEthernet0/0
description connection to firewall
ip address 172.16.20.146 255.255.255.240
duplex auto
speed auto

router ospf 100
log-adjacency-changes
network 172.16.20.32 0.0.0.3 area 0.0.0.0
network 172.16.20.144 0.0.0.15 area 0.0.0.2
!

---
cisco2 configuration
interface FastEthernet0/0
description firewall connection
ip address 172.16.20.145 255.255.255.240
duplex auto
speed auto
!

router ospf 100
log-adjacency-changes
network 172.16.20.36 0.0.0.3 area 0.0.0.0
network 172.16.20.144 0.0.0.15 area 0.0.0.2
!
ip classless
!

Thanks in advance.
Brgds,
Riwan

Reply via email to