Hi Amit,

On Mon, Nov 3, 2008 at 21:16, Amit Mendapara <[EMAIL PROTECTED]> wrote:
> MochiKit.HTTP.get(...)
> MochiKit.HTTP.post(...)
> MochiKit.HTTP.JSON.get(...)
> MochiKit.HTTP.JSON.post(...)
> MochiKit.HTTP.Cookie.get(...)
> MochiKit.HTTP.Cookie.set(...)
> MochiKit.HTTP.Cookie.del(...)
>
> and so on...
>
> would be nice.

I agree, these do indeed look very nice - and in designing a library
from scratch I would really consider using namespaces like that.
However, we must also think of consistency with the rest of MochiKit.
Namespaces aren't really used like this and things like "getCookie"
etc. rhyme more closely with the existing naming scheme.

Say you knew all other parts of MochiKit and had to guess on the name
of the function to set a cookie. Your first guess would most likely be
"setCookie" and "Cookie.set" might not even come to mind.

cheers,
Arnar

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"MochiKit" group.
To post to this group, send email to mochikit@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/mochikit?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to