Dear Daisuke,
I think your new module is a great addition to Params::Validate but I
think the naming should imply it's relation to Params::Validate.
Perhaps it should be named
Params::Validate::Derivable
or something along those lines.
If nothing else, the one line description in the NAME section should
change from:
Provide Subclass-able Validation Mechanism
to
Provide Subclass-able Validation Mechanism for Params::Validate
Regards,
--
Carter's Compass: I know I'm on the right track when,
by deleting something, I'm adding functionality.