* Chris Dolan <[EMAIL PROTECTED]> [2005-08-09 17:05]:
> I like to Pod:: namespace, but that's mostly for modules that
> convert from POD, not to POD. One exception is Pod::HTML2Pod,
> which leads me to one option:
>
> Pod::ASDoc2Pod
>
> Any other ideas? Good words to pick from: Actionscript, ASDoc,
> JavaDoc, Pod, Text. Since this is just a text => text
> conversion, names that include "Flash" or "SWF" are not
> appropriate, I think.
I do think the Pod:: namespace is appropriate for this. The
primary purpose of the module has to do with POD, so that’s where
it should be filed.
I don’t like the 2Pod bit – both for the (common and established;
unfortunately) abuse of “2” just to save a character as well as
because the “to POD” part really is redundant. What you want is a
simple “From.”
I also think the “AS” acronym is way too opaque for this. I’m not
sure it needs to mention “Doc,” though “Javadoc” would be too
much.
So I’d say this module’s name is
Pod::FromActionScriptDoc
or if you think it’s unambiguous enough, maybe
Pod::FromActionScript
both of which are plain, descriptive and memorable.
Regards,
--
#Aristotle
*AUTOLOAD=*_=sub{s/(.*)::(.*)/print$2,(",$\/"," ")[defined wantarray]/e;$1};
&Just->another->Perl->hacker;