On Fri, Jun 26, 2009 at 04:06:28PM -0500, Dave Rolsky wrote:
> Here's some initial TODOs:
>
> * POD docs for every method provided. Some providers have docs, some  
> don't.

I'm going to move all POD into the Trait classes.  I'm leaning towards thinking
that the MethodProviders are an implementation detail that should be hidden.

> * I just took a look at Bag for the first time, and it's not a bag, it's 
> a CountingHash (CounterHash, HashCounter?). A bag is a multi-set (like a  
> set, but allows dupes). Now is a good time to rename it.

I'm going to rename everything to live under
Moose::Meta::Attribute::Trait::Native (yes, I've come around).  Short names
will stay the same.

I'm going to remove Collection:: from the trait names; I think it's
unnecessary, especially since Trait::Collection is empty.

Bag is going to be renamed to Hash::Counter, probably.  Counter is secretly
Num::Counter, or something, though not really since Num doesn't exist (yet).

Things we want to do in the future that do not block coring:

* inlining
* real delegation, somehow, instead of faked-up delegation (this requires some
  kind of real boxing, either redone or through making sure that Moose::Autobox
  agrees on method names with AH)

Things that this isn't:

* boxing
* a standard set of interfaces for common types/data structures

hdp.

Reply via email to