On 2013/03/27 17:38, Anton Khirnov <an...@khirnov.net> wrote:
> Move some variables shared between multiple functions to a struct so the
> functions don't need too many parameters.
> 
> Move initializing the decoder into a separate function to improve
> readability and reduce cleanup code duplication.

Emits clang compiler warning:

src/decoder/FfmpegDecoderPlugin.cxx:511:45: error: missing field
'avctx' initializer
      [-Werror,-Wmissing-field-initializers]
        struct ffmpeg_decoder_context dec = { NULL };

Here, C++ is different from C.

------------------------------------------------------------------------------
Minimize network downtime and maximize team effectiveness.
Reduce network management and security costs.Learn how to hire 
the most talented Cisco Certified professionals. Visit the 
Employer Resources Portal
http://www.cisco.com/web/learning/employer_resources/index.html
_______________________________________________
Musicpd-dev-team mailing list
Musicpd-dev-team@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/musicpd-dev-team

Reply via email to