Thanks to all who responded, the answer turned out to be user error. The .NASL scripts in use were from 14th November and the dates on the ones that fix this started at 19th November. So contrary to my earlier note, I had been caught by out of date files. Apologies for this oversight.
All it took was to copy the correct scripts, rerun, and all is well. Richard
