On 29.6.2017 22:08, Simon Horman wrote: > Add a helper to allow switchdev ops to be set if NET_SWITCHDEV is configured > and do nothing otherwise. This allows for slightly cleaner code which > uses switchdev but does not select NET_SWITCHDEV. > > Signed-off-by: Simon Horman <simon.hor...@netronome.com> > --- > include/net/switchdev.h | 4 ++++ > 1 file changed, 4 insertions(+) > > diff --git a/include/net/switchdev.h b/include/net/switchdev.h > index c784a6ac6ef1..8ae9e3b6392e 100644 > --- a/include/net/switchdev.h > +++ b/include/net/switchdev.h > @@ -217,6 +217,8 @@ void switchdev_port_fwd_mark_set(struct net_device *dev, > > bool switchdev_port_same_parent_id(struct net_device *a, > struct net_device *b); > + > +#define SWITCHDEV_SET_OPS(netdev, ops) ((netdev)->switchdev_ops = (ops)) > #else > > static inline void switchdev_deferred_process(void) > @@ -322,6 +324,8 @@ static inline bool switchdev_port_same_parent_id(struct > net_device *a, > return false; > } > > +#define SWITCHDEV_SET_OPS(netdev, ops) do {} while (0) > + > #endif > > #endif /* _LINUX_SWITCHDEV_H_ */ >
Acked-by: Ivan Vecera <ivec...@redhat.com>