From: David Ahern <dsah...@gmail.com>

iproute2 currently uses ifinfomsg as the header for all dumps using the
wilddump headers. This is wrong as each message type actually has its own
header type. While the kernel has traditionally let it go as it for the
most part only uses the family entry, the use of kernel side filters is
increasing to alter what is returned on a request. The kernel side filters
really need to use the proper header type.

To that end, fix iproute2 to use the proper header struct for the GET type.

David Ahern (11):
  libnetlink: Convert GETADDR dumps to use rtnl_addrdump_req
  libnetlink: Convert GETROUTE dumps to use rtnl_routedump_req
  libnetlink: Convert GETADDRLABEL dumps to use rtnl_addrlbldump_req
  libnetlink: Convert GETMDB dumps to use rtnl_mdbdump_req
  libnetlink: Convert GETNETCONF dumps to use rtnl_netconfdump_req
  libnetlink: Convert GETRULE dumps to use rtnl_ruledump_req
  libnetlink: Convert GETNEIGH dumps to use rtnl_neighdump_req
  libnetlink: Convert GETNEIGHTBL dumps to use rtnl_neightbldump_req
  libnetlink: Convert GETNSID dumps to use rtnl_nsiddump_req
  libnetlink: Rename rtnl_wilddump_* to rtnl_linkdump_*
  libnetlink: Rename rtnl_wilddump_stats_req_filter to
    rtnl_statsdump_req_filter

 bridge/link.c        |   4 +-
 bridge/mdb.c         |   2 +-
 bridge/vlan.c        |  10 +---
 include/libnetlink.h |  30 ++++++++--
 ip/ipaddress.c       |  10 ++--
 ip/ipaddrlabel.c     |   4 +-
 ip/iplink.c          |   4 +-
 ip/iplink_xstats.c   |   4 +-
 ip/ipmroute.c        |   2 +-
 ip/ipnetconf.c       |   3 +-
 ip/ipnetns.c         |   2 +-
 ip/ipntable.c        |   2 +-
 ip/iproute.c         |   4 +-
 ip/iprule.c          |   2 +-
 ip/iptoken.c         |   2 +-
 ip/iptuntap.c        |   2 +-
 ip/rtmon.c           |   2 +-
 ip/tunnel.c          |   2 +-
 lib/libnetlink.c     | 164 ++++++++++++++++++++++++++++++++++++++++++++++++---
 lib/ll_map.c         |   2 +-
 misc/arpd.c          |   2 +-
 misc/ifstat.c        |   6 +-
 22 files changed, 210 insertions(+), 55 deletions(-)

-- 
2.11.0

Reply via email to