Refactor the .flow_dissect procedure to call the common helper instead of open-coding the header displacement.
Cc: Andrew Lunn <and...@lunn.ch> Signed-off-by: Vladimir Oltean <vladimir.olt...@nxp.com> --- net/dsa/tag_edsa.c | 9 +-------- 1 file changed, 1 insertion(+), 8 deletions(-) diff --git a/net/dsa/tag_edsa.c b/net/dsa/tag_edsa.c index 275e7d931b1a..ae883124f679 100644 --- a/net/dsa/tag_edsa.c +++ b/net/dsa/tag_edsa.c @@ -192,19 +192,12 @@ static struct sk_buff *edsa_rcv(struct sk_buff *skb, struct net_device *dev, return skb; } -static void edsa_tag_flow_dissect(const struct sk_buff *skb, __be16 *proto, - int *offset) -{ - *offset = 8; - *proto = ((__be16 *)skb->data)[3]; -} - static const struct dsa_device_ops edsa_netdev_ops = { .name = "edsa", .proto = DSA_TAG_PROTO_EDSA, .xmit = edsa_xmit, .rcv = edsa_rcv, - .flow_dissect = edsa_tag_flow_dissect, + .flow_dissect = dsa_tag_generic_flow_dissect, .overhead = EDSA_HLEN, }; -- 2.25.1