Pavel Emelyanov wrote:
The name struct net is too generic. There already were
some people who wanted to have some better name (for
easier grep for example). I propose the struct netns one.

The patch is (already) huge (sorry), but it's nothing but
  sed -e s/struct net\>/struct netns/g

If this name is bad as well, let's select a new one
before the struct net floods the kernel.

[ SNIP ]

--- a/include/linux/nsproxy.h
+++ b/include/linux/nsproxy.h
@@ -29,7 +29,7 @@ struct nsproxy {
        struct mnt_namespace *mnt_ns;
        struct pid_namespace *pid_ns;
        struct user_namespace *user_ns;
-       struct net           *net_ns;
+       struct netns         *net_ns;

IMHO, if we want to be consistent with all the rest of the namespaces, that should be net_namespace.

[ SNIP ]
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to