Stephen Hemminger wrote:
How about:

static int eth_validate_addr(const struct net_device *dev)
{
        return is_valid_ether_addr(dev->dev_addr) ? 0 : -EINVAL;
}

hmmm -- its a slow path, so I don't see the value of marking the argument 'const' -- right now this implementation merely reads the dev->dev_addr[], but that need not always be the case.

And I don't see the value of squashing everything onto one line, IMO the current version is more readable.

        Jeff



-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to