On Wed, Apr 22, 2015 at 3:04 PM, Alexei Starovoitov <a...@plumgrid.com> wrote: > On 4/21/15 9:59 PM, Cong Wang wrote: >> >> On Tue, Apr 21, 2015 at 12:27 PM, Alexei Starovoitov <a...@plumgrid.com> >> wrote: >>> >>> ingress qdisc should return NET_XMIT_* values just like all other qdiscs. >>> >> >> XMIT already means egress... > > > may be then it should be renamed as well. > from include/linux/netdevice.h: > /* qdisc ->enqueue() return codes. */ > #define NET_XMIT_SUCCESS 0x00 > ... > > the point is that qdisc->enqeue() must return NET_XMIT_* values. > ingress qdisc is violating this and therefore should be fixed.
XMIT is non-sense for ingress, you really need to pick another name for it if TC_ACT_OK isn't okay for you (it is okay for me). > >>> Since it's invoked via qdisc_enqueue_root() (which suppose to return >>> only NET_XMIT_* values as well), it was working by accident, >>> since TC_ACT_* values fit within NET_XMIT_MASK. >>> >> >> Why not just add a BUILD_BUG_ON() to capture this? > > > ingress qdisc returning TC_ACT_* values is an obvious layering > violation. I'm puzzled why it's been this way for so long. Why? Everyone knows ingress is the only qdisc on ingress and it has no queue and can only accept filters (actions are on filters). > Adding BUILD_BUG_ON is not an option. > It at least tells people we know their value are same, IOW, not a bug. I don't see the need for the change except a BUILD_BUG_ON(). -- To unsubscribe from this list: send the line "unsubscribe netdev" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html