Second version of the patch extends to a patchset. Basically this patchset
brings object structure back which disappeared with recent Vivien's patchset.
Also it does a bit of naming changes in order to get the things in line.
Also, object id is put back into object structure.
Thanks to Scott and Vivien for review and suggestions.

Jiri Pirko (6):
  switchdev: rename SWITCHDEV_OBJ_* enum values to SWITCHDEV_OBJ_ID_*
  switchdev: rename SWITCHDEV_ATTR_* enum values to SWITCHDEV_ATTR_ID_*
  switchdev: rename switchdev_obj_vlan to switchdev_obj_port_vlan
  switchdev: rename switchdev_obj_fdb to switchdev_obj_port_fdb
  switchdev: bring back switchdev_obj and use it as a generic object
    param
  switchdev: push object ID back to object structure

 Documentation/networking/switchdev.txt         | 15 +++--
 drivers/net/ethernet/mellanox/mlxsw/switchx2.c |  2 +-
 drivers/net/ethernet/rocker/rocker.c           | 80 ++++++++++++----------
 include/net/switchdev.h                        | 76 ++++++++++++---------
 net/bridge/br_fdb.c                            |  5 +-
 net/bridge/br_stp.c                            |  2 +-
 net/bridge/br_vlan.c                           | 10 +--
 net/core/net-sysfs.c                           |  2 +-
 net/core/rtnetlink.c                           |  2 +-
 net/dsa/slave.c                                | 72 +++++++++++---------
 net/switchdev/switchdev.c                      | 93 ++++++++++++++------------
 11 files changed, 199 insertions(+), 160 deletions(-)

-- 
1.9.3

--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to