From: Salil Mehta <salil.me...@huawei.com>
Date: Thu, 26 Nov 2015 07:14:06 +0000

> -#define ENABLE               (0x1)
> -#define DISABLE              (0x0)
> +#define ENABLE               0x1
> +#define DISABLE              0x0

Defining such common macros names for such incredibly simple boolean values
is asking for trouble, in particular it can possibly collide with other
defines in the global namespace.

Use "true", "false", and the "bool" type, because that is exactly how you
are using these values.

Thanks.


--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to