> 
>      # a.f()  ==  f(a)    ==> I don't use it. Unnecessary parentheses hurt 
> readability. Note that in languages such as Eiffel, this is normal.
>      

personally, I like the Scala convention:

  * if it does side effects, and/or mutate state, then use parens:


    
    
      f.read()
      v.print()
      t.makeChild()
    

  * otherwise, if it's equivalent to a field and/or processing time is 
negligible, drop the parens:


    
    
      a.value
      x.asInt
      treeNode.left
    

etc. 

Reply via email to