Michael Blow has posted comments on this change.

Change subject: Cleanup and bug fixes in Feeds pipeline
......................................................................


Patch Set 12:

(5 comments)

https://asterix-gerrit.ics.uci.edu/#/c/1523/12/asterixdb/asterix-external-data/src/main/java/org/apache/asterix/external/dataflow/FeedRecordDataFlowController.java
File 
asterixdb/asterix-external-data/src/main/java/org/apache/asterix/external/dataflow/FeedRecordDataFlowController.java:

PS12, Line 64:                     synchronized (this) {
             :                         wait(INTERVAL);
             :                     }
Does anyone notify "this"?  If not, this should be replaced with 
Thread.sleep(INTERVAL);


https://asterix-gerrit.ics.uci.edu/#/c/1523/12/hyracks-fullstack/hyracks/hyracks-data/hyracks-data-std/src/main/java/org/apache/hyracks/data/std/api/AbstractPointable.java
File 
hyracks-fullstack/hyracks/hyracks-data/hyracks-data-std/src/main/java/org/apache/hyracks/data/std/api/AbstractPointable.java:

PS12, Line 35: copy
Can we rename to copyTo/Into for clarity?


PS12, Line 36: arraycopy
> boundary/length check of copy?
I guess arraycopy will throw ArrayIndexOutOfBoundsException, should we just add 
this to javadoc @throws?


https://asterix-gerrit.ics.uci.edu/#/c/1523/12/hyracks-fullstack/hyracks/hyracks-dataflow-std/src/main/java/org/apache/hyracks/dataflow/std/connectors/PartitionDataWriter.java
File 
hyracks-fullstack/hyracks/hyracks-dataflow-std/src/main/java/org/apache/hyracks/dataflow/std/connectors/PartitionDataWriter.java:

PS12, Line 134:         failed = true;
do we need a new flag?  can we just use isOpen for this?


PS12, Line 156:         if (!failed) {
should we flush if not opened?  can we eliminate failed flag and just use 
isOpen array?


-- 
To view, visit https://asterix-gerrit.ics.uci.edu/1523
To unsubscribe, visit https://asterix-gerrit.ics.uci.edu/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Ie97b2133ebecb7380cf0ba336e60ed714d06f8ee
Gerrit-PatchSet: 12
Gerrit-Project: asterixdb
Gerrit-Branch: master
Gerrit-Owner: abdullah alamoudi <bamou...@gmail.com>
Gerrit-Reviewer: Jenkins <jenk...@fulliautomatix.ics.uci.edu>
Gerrit-Reviewer: Michael Blow <mb...@apache.org>
Gerrit-Reviewer: Yingyi Bu <buyin...@gmail.com>
Gerrit-Reviewer: abdullah alamoudi <bamou...@gmail.com>
Gerrit-HasComments: Yes

Reply via email to