[ 
https://issues.apache.org/jira/browse/OFBIZ-11127?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Pawan Verma updated OFBIZ-11127:
--------------------------------
    Description: 
Method 'getCartObject' and 'destroyCart'of ShoppingCartEvents class accessed 
incorrectly at some places in ShoppingCartEvents class.

It should be called by following below syntax:

getCartObject(parameters);

destroyCart(request, response);

 

But, at some places, it is called incorrectly like this:

ShoppingCartEvents.getCartObject(parameters)

ShoppingCartEvents.destroyCart(request, response);

 

 

  was:
Method 'getCartObject' of ShoppingCartEvents class accessed incorrectly at some 
places in ShoppingCartEvents class.

It should be called by following below syntax:

getCartObject(parameters);

 

But, at some places, it is called incorrectly like this:

ShoppingCartEvents.getCartObject(parameters)

 

 


> Code improvement in ShoppingCartEvents.java
> -------------------------------------------
>
>                 Key: OFBIZ-11127
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-11127
>             Project: OFBiz
>          Issue Type: Improvement
>          Components: order
>    Affects Versions: Trunk
>            Reporter: Amit Gadaley
>            Assignee: Pawan Verma
>            Priority: Minor
>         Attachments: OFBIZ-11127.patch
>
>
> Method 'getCartObject' and 'destroyCart'of ShoppingCartEvents class accessed 
> incorrectly at some places in ShoppingCartEvents class.
> It should be called by following below syntax:
> getCartObject(parameters);
> destroyCart(request, response);
>  
> But, at some places, it is called incorrectly like this:
> ShoppingCartEvents.getCartObject(parameters)
> ShoppingCartEvents.destroyCart(request, response);
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

Reply via email to