Yicong-Huang opened a new issue, #6089: URL: https://github.com/apache/texera/issues/6089
### Task Summary In `build.sbt`, `asfLicensingSettings` is misnamed. Besides ASF licensing it also folds in the jacoco coverage-report format and the universal JVM flags — two concerns unrelated to licensing. Both the name and the `coverageReportSettings` comment mislead readers into thinking coverage is a licensing concern. Cleanup: make `asfLicensingSettings` hold only the licensing settings, and move the shared per-module bundle (licensing + coverage + JVM flags) into a clearly named `commonModuleSettings`. Behavior-preserving. ### Task Type - [x] Refactor / Cleanup - [ ] DevOps / Deployment / CI - [ ] Testing / QA - [ ] Documentation - [ ] Performance - [ ] Other -- This is an automated message from the Apache Git Service. To respond to the message, please log on to GitHub and use the URL above to go to the specific comment. To unsubscribe, e-mail: [email protected] For queries about this service, please contact Infrastructure at: [email protected]
