[ 
https://issues.apache.org/jira/browse/OAK-10458?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17770460#comment-17770460
 ] 

Nitin Gupta edited comment on OAK-10458 at 9/29/23 2:16 PM:
------------------------------------------------------------

Seems like the compression is being read from system property here as well 
https://github.com/apache/jackrabbit-oak/blob/trunk/oak-run-commons/src/main/java/org/apache/jackrabbit/oak/index/indexer/document/incrementalstore/IncrementalStoreBuilder.java#L57
  and 
https://github.com/apache/jackrabbit-oak/blob/trunk/oak-run-commons/src/main/java/org/apache/jackrabbit/oak/index/indexer/document/incrementalstore/IncrementalStoreBuilder.java#L57
 here too. We would need to change the default here as well.

Might be best to move this out to some util class and use it from there in 
different places. 
IndexStoreUtils 
(https://github.com/apache/jackrabbit-oak/blob/trunk/oak-run-commons/src/main/java/org/apache/jackrabbit/oak/index/indexer/document/indexstore/IndexStoreUtils.java)
 might be a good candidate

However I see there that gzip has been set as default for naming conventions 
for maintaining backward compat 

{code:java}
 /**
     * This function by default uses GNU zip as compression algorithm for 
backward compatibility.
     */
    public static String getSortedStoreFileName(boolean compressionEnabled) {
        return getSortedStoreFileName(compressionEnabled ? Compression.GZIP : 
Compression.NONE);
    }
{code}


Also maybe we can expose the default value so that it can be used by clients as 
well.


was (Author: nitigup):
Seems like the compression is being read from system property here as well 
https://github.com/apache/jackrabbit-oak/blob/trunk/oak-run-commons/src/main/java/org/apache/jackrabbit/oak/index/indexer/document/incrementalstore/IncrementalStoreBuilder.java#L57
  and 
https://github.com/apache/jackrabbit-oak/blob/trunk/oak-run-commons/src/main/java/org/apache/jackrabbit/oak/index/indexer/document/incrementalstore/IncrementalStoreBuilder.java#L57
 here too. We would need to change the default here as well.

Might be best to move this out to some util class and use it from there in 
different places. Also maybe we can expose the default value so that it can be 
used by clients as well.

> Indexing job: Make LZ4 the default compression algorithm in OAK
> ---------------------------------------------------------------
>
>                 Key: OAK-10458
>                 URL: https://issues.apache.org/jira/browse/OAK-10458
>             Project: Jackrabbit Oak
>          Issue Type: Improvement
>          Components: indexing
>            Reporter: Nuno Santos
>            Priority: Minor
>              Labels: Indexing
>             Fix For: 1.58.0
>
>




--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to