OpenBSD src changes summary for 2017-11-17
==========================================

lib/libfuse                             regress/sys
sbin/ifconfig                           share/dict
share/man                               sys/arch/amd64/include
sys/arch/i386/include                   sys/dev/ofw
sys/kern                                sys/miscfs/fuse
sys/net                                 sys/netinet
sys/netinet6                            usr.bin/tmux
usr.sbin/pppd                           

== lib =============================================================== 01/07 ==

  http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/lib

libfuse

  ~ fuse.h                                ~ fuse_ops.c

  > Fixes the following bugs when getcwd(3) is used on a fuse file system
  > Endless loop if directory nested more than one level from root of file
  > system
  > Current directory not found if the parent directory contains more children
  > than
  > will fit in the buffer passed to VOP_READDIR(9)
  > Open and close directory in fusefs_readdir if dir is not already open.
  > Now behaves as if readdir_ino option was passed to fuse so that directories
  > in
  > path have a valid ino.
  > ok mpi@ (helg@)

  ~ fuse.c                                

  > Implement safe signal handling and handle unmount failure gracefully.
  > ok mpi@ (helg@)

== regress =========================================================== 02/07 ==

  http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/regress

sys

  + net/loop/Makefile                     + net/loop/pf.conf

  > New import:
  >     Set up two loopback interfaces in different routing domains.  Try

  ~ net/Makefile                          

  > Link loopback test to build. (bluhm@)

  ~ net/loop/Makefile                     ~ net/loop/pf.conf

  > Let packets jump between routing domains until the ttl is used up.
  > Use tcpdump to check that the ttl decrements to one. (bluhm@)

== sbin ============================================================== 03/07 ==

  http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/sbin

ifconfig

  ~ ifconfig.8                            ~ ifconfig.c

  > replace the deletetunnel option with -tunnel
  > ok bluhm@ (benno@)

== share ============================================================= 04/07 ==

  http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/share

dict

  ~ web2                                  

  > Add the word "software" to our dictionary to help passing the test
  > of Sub::Attribute Perl module.
  > OK jmc@ (bluhm@)

man

  ~ man5/bsd.port.mk.5                    

  > the COMPILER transition mechanism is gone (naddy@)

  ~ man9/if_rxr_init.9                    

  > add if_rxr_livelocked so rxr users can request backpressure themselves.
  > right now the rx ring moderation code makes a decision globally
  > that a machine is livelocked, and uses that to apply backpressure
  > on all the rx rings. we're moving toward having the network stack
  > run on multiple cpus, and fed from multiple rx rings. if_rxr_livelocked
  > lets a driver apply backpressure explicitely if something tells it
  > that whatever is consuming previous packets cannot keep up.
  > while here expose the current ring watermark with if_rxr_cwm.
  > tweaks and ok visa@ (dlg@)

  ~ man4/man4.macppc/openprom.4           ~ man4/man4.sparc64/openprom.4

  > add some missing markup; from artturi alm (jmc@)

== sys =============================================================== 05/07 ==

  http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/sys

arch/amd64/include

  ~ vmmvar.h                              

  > vmmvar.h changes for upcoming cdrom support in vmd(8).
  > Diff from carlos cardenas, thanks (mlarkin@)

arch/i386/include

  ~ vmmvar.h                              

  > vmmvar.h changes for upcoming cdrom support in vmd(8).
  > Diff from carlos cardenas, thanks (mlarkin@)

dev/ofw

  ~ fdt.c                                 

  > Make OF_getnodebyname() scan its child nodes instead of its peer nodes.
  > This still deviates from the implementation we have on macppc, but we only
  > ever use OF_getnodebyname() to find child nodes in our tree.
  > ok tom@, visa@ (kettenis@)

kern

  ~ kern_pledge.c                         

  > permit IPV6_V6ONLY in sockopt
  > OK deraadt@ (abieber@)

miscfs/fuse

  ~ fuse_vnops.c                          

  > Fixes the following bugs when getcwd(3) is used on a fuse file system
  > Endless loop if directory nested more than one level from root of file
  > system
  > Current directory not found if the parent directory contains more children
  > than
  > will fit in the buffer passed to VOP_READDIR(9)
  > Open and close directory in fusefs_readdir if dir is not already open.
  > Now behaves as if readdir_ino option was passed to fuse so that directories
  > in
  > path have a valid ino.
  > ok mpi@ (helg@)

net

  ~ if_var.h                              ~ if.c

  > add if_rxr_livelocked so rxr users can request backpressure themselves.
  > right now the rx ring moderation code makes a decision globally
  > that a machine is livelocked, and uses that to apply backpressure
  > on all the rx rings. we're moving toward having the network stack
  > run on multiple cpus, and fed from multiple rx rings. if_rxr_livelocked
  > lets a driver apply backpressure explicitely if something tells it
  > that whatever is consuming previous packets cannot keep up.
  > while here expose the current ring watermark with if_rxr_cwm.
  > tweaks and ok visa@ (dlg@)

  ~ if_etherip.c                          

  > Move etherip counters and their allocation to etherip(4)
  > gif(4) now depends on etherip(4) but this is a temporary drawback: we
  > can get rid of etherip_init(), called from the protocol switch, and
  > ip_ether.c should stop using etherip counters once it is clear that this
  > file doesn't handle ethernet-in-IP any more.
  > ok visa@ as part of a larger diff, ok mpi@ (jca@)

  ~ if_etherip.c                          

  > Don't pass unhandled packets to gif(4)
  > This was useful for the migration path, it's not since gif(4) can't be
  > added to a bridge any more.  ok visa@ as part of a larger diff, ok mpi@
  > (jca@)

  ~ if_etherip.c                          ~ if_etherip.h

  > Move etherip_allow where it is used
  > While here, drop the declaration in headers, since the variable is used
  > in a single file.  ok visa@ mpi@ (jca@)

  ~ if_gif.c                              

  > Rename functions that now handle only MPLS-in-IP
  > ok visa@ mpi@ (jca@)

  ~ if_etherip.c                          ~ if_etherip.h

  > Rename etherip sysctl handler, there's no conflict with ip_ether.c any more
  > ok visa@ mpi@ (jca@)

  ~ if_gif.c                              

  > #if -> #ifdef for consistency
  > ok visa@ as part of a larger diff (jca@)

netinet

  ~ in_proto.c                            ~ ip_ether.c
  ~ ip_ether.h                            

  > Move etherip counters and their allocation to etherip(4)
  > gif(4) now depends on etherip(4) but this is a temporary drawback: we
  > can get rid of etherip_init(), called from the protocol switch, and
  > ip_ether.c should stop using etherip counters once it is clear that this
  > file doesn't handle ethernet-in-IP any more.
  > ok visa@ as part of a larger diff, ok mpi@ (jca@)

  ~ ip_ether.c                            ~ in_proto.c

  > Drop all Ethernet-in-IP support from gif(4)
  > As a result, ip_ether.c now only deals with MPLS-in-IP.  The next
  > commits will move & rename stuff to make this clear.  ok visa@ mpi@ (jca@)

  ~ ip_ether.c                            

  > Drop etheripstat use in ip_ether.c
  > Those functions only handle MPLS-in-IP packets, it makes little sense to
  > count those as ethernet-in-IP.  ok visa@ mpi@ (jca@)

  ~ ip_ether.c                            ~ ip_ether.h

  > Move etherip_allow where it is used
  > While here, drop the declaration in headers, since the variable is used
  > in a single file.  ok visa@ mpi@ (jca@)

  ~ in_proto.c                            ~ ip_ether.c
  ~ ip_ether.h                            

  > Rename functions that now handle only MPLS-in-IP
  > ok visa@ mpi@ (jca@)

  ~ ip_ether.c                            ~ ip_ether.h

  > Add ifdef MPLS around all the MPLS-in-IP code
  > ok visa@ mpi@ (jca@)

  ~ in_proto.c                            

  > Rename etherip sysctl handler, there's no conflict with ip_ether.c any more
  > ok visa@ mpi@ (jca@)

netinet6

  ~ in6_proto.c                           

  > Drop all Ethernet-in-IP support from gif(4)
  > As a result, ip_ether.c now only deals with MPLS-in-IP.  The next
  > commits will move & rename stuff to make this clear.  ok visa@ mpi@ (jca@)

== usr.bin =========================================================== 06/07 ==

  http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/usr.bin

tmux

  ~ cmd-select-pane.c                     

  > Allow formats in selectp -T, from Thomas Adam. (nicm@)

== usr.sbin ========================================================== 07/07 ==

  http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/usr.sbin

pppd

  ~ auth.c                                ~ chap.c
  ~ pppd.h                                ~ upap.c

  > Use explicit_bzero to erase secrets
  > from Scott Cheloa, ok tb@ (jca@)

===============================================================================
_______________________________________________
odc mailing list
odc@squish.net
http://www.squish.net/mailman/listinfo/odc

Reply via email to