Hi Oleg,

Patch has been applied, however see comments below:

<snip>

> +static struct ofono_call_forwarding_condition *cf_cond_find(GSList *l, int 
> cls)
>  {
> -     const struct ofono_call_forwarding_condition *c = a;
> -     int cls = GPOINTER_TO_INT(b);
> +     for (; l; l = l->next)
> +             if (((struct ofono_call_forwarding_condition *)
> +                             (l->data))->cls == cls)

I don't really find all this casting more readable, so I changed this
back to more or less the old way of assigning an
ofono_call_forwarding_condition variable first.  The parentheses make my
head hurt, so lets avoid such constructs in the future.

<snip>

>                       if (new_cfu)
>                               number = "";
>                       else {
> -                             lc = l->data;
> -
> -                             number = phone_number_to_string(

Something went wrong with your merge here, so I had to fix this manually
and amend your patch.

>                                                       &lc->phone_number);
>                       }
>  

Regards,
-Denis
_______________________________________________
ofono mailing list
ofono@ofono.org
http://lists.ofono.org/listinfo/ofono

Reply via email to