+        uuid = has_dun_uuid(iter);
+
+        if (bt_device != NULL && uuid == FALSE)
+            bluetooth_device_unregister(path);
+
+        else if (bt_device == NULL && uuid == TRUE)
+            bluetooth_device_register(proxy);
+    }

I find this a bit hard to read. What about

     if (uuid)
         if (bt_device != NULL)
             bluetooth_device_unregister(path);
     else
         if (bt_device == NULL)
             bluetooth_device_regster(path);

Obviously, some braces are needed :)

_______________________________________________
ofono mailing list
ofono@ofono.org
http://lists.ofono.org/listinfo/ofono

Reply via email to