Hi RP,

Thanks for the comments. Sounds good to me. I'll send another patchset.

I'll see if I can also set up a renaming patch for the other IPKG variables for
review comments.

Kind regards,
Michael

-- 
BMW Car IT GmbH
Michael Ho
Spezialist Entwicklung – Build and Release Engineering
Lise-Meitner-Straße 14
89081 Ulm

Tel.: ­+49-731-37804-071
Mobil: +49-152-54980-471
Fax: +49-731-37804-001
Mail: michael...@bmw-carit.de 
Web: http://www.bmw-carit.de <http://www.bmw-carit.de/>
-------------------------------------------------------------------------
BMW Car IT GmbH
Geschäftsführer: Kai-Uwe Balszuweit und Michael Böttrich
Sitz und Registergericht: München HRB 134810
-------------------------------------------------------------------------
 

On 05.02.21, 13:33, "Richard Purdie" <richard.pur...@linuxfoundation.org> 
wrote:

    On Fri, 2021-02-05 at 09:51 +0100, Michael Ho wrote:
    > From: Michael Ho <michael...@bmw.de>
    > 
    > The OpkgPM class has several constructor options that allows for skipping
    > the ipk repository set up and controlling the ipk repository directory. 
This
    > commit exposes these option via the OpkgRootfs class so others can make 
use
    > of them if they wish to.
    > 
    > Adds the bitbake variables "IPKGREPO_TARGET_PREPARED" and 
"IPKGREPO_TARGET"
    > to act as the interfaces.
    > 
    > Signed-off-by: Michael Ho <michael...@bmw.de>
    > ---
    >  meta/lib/oe/package_manager/ipk/rootfs.py | 14 ++++++++++++--
    >  1 file changed, 12 insertions(+), 2 deletions(-)
    > 
    > diff --git a/meta/lib/oe/package_manager/ipk/rootfs.py 
b/meta/lib/oe/package_manager/ipk/rootfs.py
    > index 26dbee6..6313b72 100644
    > --- a/meta/lib/oe/package_manager/ipk/rootfs.py
    > +++ b/meta/lib/oe/package_manager/ipk/rootfs.py
    > @@ -129,6 +129,14 @@ class PkgRootfs(DpkgOpkgRootfs):
    >          self.manifest = PkgManifest(d, manifest_dir)
    >          self.opkg_conf = self.d.getVar("IPKGCONF_TARGET")
    >          self.pkg_archs = self.d.getVar("ALL_MULTILIB_PACKAGE_ARCHS")
    > +        self.opkg_repo = self.d.getVar("IPKGREPO_TARGET")
    > +        self.opkg_repo_prepared = 
self.d.getVar("IPKGREPO_TARGET_PREPARED")
    > +
    > +        kwargs = {}
    > +        if self.opkg_repo:
    > +            kwargs["ipk_repo_workdir"] = self.opkg_repo
    > +        if self.opkg_repo_prepared:
    > +            kwargs["prepare_index"] = False
    >  
    > 

    It seems reasonable to expose them, I'd just suggest that we don't put
    them in self here but do something like:

    +        if self.d.getVar("IPKGREPO_TARGET"):
    +            kwargs["ipk_repo_workdir"] = self.opkg_repo
    +        if self.d.getVar("IPKGREPO_TARGET_PREPARED"):
    +            kwargs["prepare_index"] = False

    and my only other concern is the naming. Somehow we need to get from
    the mess we're currently in to some kind of more consistent and
    understandable naming of variables.

    OPKG_ROOTFS_FEED_WORKDIR
    OPKG_ROOTFS_REBUILDINDEX

    maybe?

    I'd also yes, we should document them.

    Cheers,

    Richard

-=-=-=-=-=-=-=-=-=-=-=-
Links: You receive all messages sent to this group.
View/Reply Online (#147700): 
https://lists.openembedded.org/g/openembedded-core/message/147700
Mute This Topic: https://lists.openembedded.org/mt/80401750/21656
Group Owner: openembedded-core+ow...@lists.openembedded.org
Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub 
[arch...@mail-archive.com]
-=-=-=-=-=-=-=-=-=-=-=-

Reply via email to