more a style thing than anything else, but i've noticed in the layer
i'm perusing a number of examples of the form:


  do_something() {
        ... doing something ...
  }

  do_unpack[postfuncs] += "do_something"


i mention this only because my preference is to reserve the "do_"
prefix for things that will be upgraded to tasks, so that things are
clearer visually. of course the above is perfectly valid, just
something i would rather avoid. (i verified that do_something() is
nowhere being upgraded to a task.)

  to that end, i grep'ped the OE code base to see the consensus, and
ran across the following in insane.bbclass:

  # The Staging Func, to check all staging
  #addtask qa_staging after do_populate_sysroot before do_build
  do_populate_sysroot[postfuncs] += "do_qa_staging "

  # Check for patch fuzz
  do_patch[postfuncs] += "do_qa_patch "

  # Check broken config.log files, for packages requiring Gettext which
  # don't have it in DEPENDS.
  #addtask qa_configure after do_configure before do_compile
  do_configure[postfuncs] += "do_qa_configure "

the comments seem out of sync with the code, as there is no "addtask"
being run for those listed examples, they're simply being added as
postfuncs. the effect might be the same, but the comments seem
misleading. thoughts?

rday
-=-=-=-=-=-=-=-=-=-=-=-
Links: You receive all messages sent to this group.
View/Reply Online (#149817): 
https://lists.openembedded.org/g/openembedded-core/message/149817
Mute This Topic: https://lists.openembedded.org/mt/81547408/21656
Group Owner: openembedded-core+ow...@lists.openembedded.org
Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub 
[arch...@mail-archive.com]
-=-=-=-=-=-=-=-=-=-=-=-

Reply via email to