On Tue, 27 Sept 2022 at 16:17, Peter Kjellerstedt
<peter.kjellerst...@axis.com> wrote:

> Is that really useful? It cannot be many recipes where the owner
> part of the URL actually matches ${BPN}? Wouldn't it make more
> sense to instead use something like:
>
> GITHUB_OWNER ?= "${BPN}"
> GITHUB_NAME ?= "${BPN}"
> GITHUB_BASE_URI ?= 
> "https://github.com/${GITHUB_OWNER}/${GITHUB_NAME}/releases/";
>
> That way it is more evident in the recipe when GITHUB_OWNER and/or
> GITHUB_NAME is set, rather than the entire GITHUB_BASE_URI being
> redefined.

I ran some stats on the recipes in core that have been transitioned to
the class:

total: 39
same owner/same name as the recipe, no override of GITHUB_BASE_URI: 11
different owner/same name as the recipe: 14
different owner/different name as the recipe: 14

I would rather avoid adding abstractions and reducing readability by
defining even more variables, perhaps recipes that use different
owner/same name can use:
GITHUB_BASE_URI = "https://github.com/custom-owner/${BPN}/releases/";
(some already do, but not all). I also find it very useful to be able
to click on URIs on recipes, and don't like having to copy-paste-edit
bits of it
to get where I want in the browser :)

In any case, the major point here is to fix upstream version checks so
that AUH can continue do its work. A minor point is to define the base
uri (the part up to 'releases') only once, or use a default where
possible.

Alex
-=-=-=-=-=-=-=-=-=-=-=-
Links: You receive all messages sent to this group.
View/Reply Online (#171111): 
https://lists.openembedded.org/g/openembedded-core/message/171111
Mute This Topic: https://lists.openembedded.org/mt/93948089/21656
Group Owner: openembedded-core+ow...@lists.openembedded.org
Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub 
[arch...@mail-archive.com]
-=-=-=-=-=-=-=-=-=-=-=-

Reply via email to