On Wed, 2004-11-10 at 14:07, Sean Hefty wrote:
> Hal Rosenstock wrote:
> 
> > -   send_wr.wr_id = ++port_priv->wr_id;
> > +   send_wr.wr_id = (unsigned long)&agent_send_wr->send_list;
> {snip}
> > +   send_wr = (struct list_head *)(unsigned long)mad_send_wc->wr_id;
> > +   agent_send_wr =  container_of(send_wr, struct ib_agent_send_wr,
> >                                  send_list);
> 
> I think it may be clearer to set the wr_id to agent_send_wr, rather than 
> a subfield.

Yes, that would be better (clearer and less code). Patch shortly for
this.

-- Hal

_______________________________________________
openib-general mailing list
[EMAIL PROTECTED]
http://openib.org/mailman/listinfo/openib-general

To unsubscribe, please visit http://openib.org/mailman/listinfo/openib-general

Reply via email to