Google suggests that when you see that error you need to fdisk before you fmthard. See http://malsserver.blogspot.com/2008/08/mirroring-resolved-correct-way.html :
> before doing the fmthard, you have to do fdisk on the new drive. > In my case, I did 'pfexec fdisk /dev/rdsk/c4t1d0s2', it complained, I said > yes then everything was fine. > If you skip this step, you'll get: > fmthard: Partition 2 specifies the full disk and is not equal > and later: > "Partition 0 of the disk has an incorrect offset" worth a try... Chris Jordan [email protected] ---- Roy Sigurd Karlsbakk <[email protected]> wrote: > Hi all One of the rpool drives on this server died the other day, so I got a replacement that was 1 cylinder larger (60798 vs 60797). Still, I tried prtvtoc /dev/rdsk/c7d0s2 | fmthard -s - /dev/rdsk/c6d0s2 zpool replace worked and the pool resilvered within a few minutes. Now, installing grub fails. root@prv-backup:~# installgrub /boot/grub/stage1 /boot/grub/stage2 /dev/rdsk/c6d0s0 Partition 0 of the disk has an incorrect offset Unable to gather device information for /dev/rdsk/c6d0s0 Can thie be because of a bad partition table? Any idae how to fix this properly? Vennlige hilsener / Best regards roy -- Roy Sigurd Karlsbakk (+47) 97542685 [email protected] http://blogg.karlsbakk.net/ -- I all pedagogikk er det essensielt at pensum presenteres intelligibelt. Det er et elementært imperativ for alle pedagoger å unngå eksessiv anvendelse av idiomer med fremmed opprinnelse. I de fleste tilfeller eksisterer adekvate og relevante synonymer på norsk. _______________________________________________ OpenIndiana-discuss mailing list [email protected] http://openindiana.org/mailman/listinfo/openindiana-discuss _______________________________________________ OpenIndiana-discuss mailing list [email protected] http://openindiana.org/mailman/listinfo/openindiana-discuss
