Hm, looks ok so far. Can you ping yourself on the
interface IP ?
The usual stuff is to check /etc/hostname.aggr1,
/etc/hosts (should be a link to /etc/inet/hosts)
should contain the IP adress and name of the host
on that interface (it seems it does not, since your
routing table shows only the IP, not the name),
/etc/defaultrouter must have your gateway, /etc/nsswitch.conf
should have 'files' as first entry for hosts and ipnodes,
/etc/netmasks should have a class C broadcast entry for
your network, nwam should be really off, /etc/resolv.conf
should have domain, nameserver, search entries, IP forwarding/
routing service off, mtu should be 1500 (if you don't have
everything on 9000). MAC address should be nonzero, I've
a workstation at home where the netcard looses its mac address
everytime I unplug it from power...

Sometimes a simple reboot helps after heavy configuration
changes, I've also seen Cisco switches where you sometimes
have to reconfigure the ports a second time with the exactly
same configuration to get them active (and it often takes
some time until they come up), unplug/replug could help.

On 10/09/2013 11:22, Antony Brooke-Wood wrote:
Hi Udo,

I had the switch in access mode already (though I did try to force it as a
trunk out of frustration). The switch config is as follows:
interface Port-channel10
  description ARC01_LACP
  switchport mode access
!
interface GigabitEthernet0/41
  description ARC01_LACP
  switchport mode access
  channel-group 10 mode active
!
interface GigabitEthernet0/42
  description ARC01_LACP
  switchport mode access
  channel-group 10 mode active

Switch shows:
SW01#show lacp 10 internal
Channel group 10
                             LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number
  State
Gi0/41    SP      bndl      32768         0xA       0xA     0x12A
0x3C
Gi0/42    SP      bndl      32768         0xA       0xA     0x12B
0x3C

SW01#show lacp 10 neighbor
Channel group 10 neighbors
Partner's information:
                   LACP port                        Admin  Oper   Port
  Port
Port      Flags   Priority  Dev ID          Age    key    Key    Number
  State
Gi0/41    SA      4096      6805.ca11.19a6   8s    0x0    0x3EA  0x4
0x3D
Gi0/42    SA      4096      6805.ca11.19a6   5s    0x0    0x3EA  0x5
0x3D

Port: Gi0/42
------------

Port state    = Up Mstr Assoc In-Bndl
Channel group = 10          Mode = Passive         Gcchange = -
Port-channel  = Po10        GC   =   -             Pseudo port-channel =
Po10
Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast
LACPDUs.
         A - Device is in active mode.        P - Device is in passive mode.

Local information:
                             LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number
  State
Gi0/42    SP      bndl      32768         0xA       0xA     0x12B
0x3C

Partner's information:

                   LACP port                        Admin  Oper   Port
  Port
Port      Flags   Priority  Dev ID          Age    key    Key    Number
  State
Gi0/42    SA      4096      6805.ca11.19a6   6s    0x0    0x3EA  0x5
0x3D

Age of the port in the current state: 0d:00h:17m:42s

The LACPDU speeds are already in synch (both set to slow/long).
I had both side set to active, but I've changed it to passive on the switch
side (no change).
I previously had the policy set only to L4, but I've changed it to L2,L3,L4
(no change).

What I really don't understand is how I got a DHCP address across the link,
but can't do anything else.

Any other ideas?


Regards,

Antony Brooke-Wood
Mobile: +61 404 460 326


On 10 September 2013 18:42, Udo Grabowski (IMK) <udo.grabow...@kit.edu>wrote:

On 10/09/2013 10:14, Antony Brooke-Wood wrote:

I am running OpenIndiana (oi_151a8) and have two NICs aggregated using
LACP
connected to a Cisco WS-C3560G-48TS. Both the server and the switch show
the aggregate link as up. But while link layer traffic is visible ('snoop'
shows ARP requests etc), I can not pass any IP traffic (ping, ssh all
fail). The really strange thing is that the aggregate link can obtain a
DHCP address, which provides the correct gateway etc. My initial thoughts
were that there was a problem with the VLAN configuration, but the switch
is running everything on VLAN1. I also tried explicitly adding this on
both
ends, but without success (OI won't let me configure a VLAN with the
native
VLAN). Any ideas?


The switch should have its ports also in a LACP group, and this
group should be VLAN access, not a trunk port, otherwise you have
to create a vlan aggr on your host also (which makes no real sense
if you only access this subnet on the host). You may also set the
policy to all layers (-P L2,L3,L4), LACPDU speed should match. We
usually prefer to set the switch to passive and host to active
mode:

interface GigabitEthernet0/14
  switchport access vlan yyyy
  switchport mode access
  channel-group 10 mode passive

If you see

switchport trunk encapsulation dot1q
switchport trunk allowed vlan yyyy
switchport mode trunk

you have a trunk port, not an access port.

Port: Gi0/14
------------

Port state    = Up Mstr Assoc In-Bndl
Channel group = 10          Mode = Passive         Gcchange = -
Port-channel  = Po10        GC   =   -             Pseudo port-channel =
Po10
Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast
LACPDUs.
         A - Device is in active mode.        P - Device is in passive mode.

Local information:
                             LACP port     Admin     Oper    Port
  Port
Port      Flags   State     Priority      Key       Key     Number
  State
Gi0/14    SP      bndl      32768         0xA       0xA     0xE
0x3C

Partner's information:

                   LACP port                        Admin  Oper   Port
  Port
Port      Flags   Priority  Dev ID          Age    key    Key    Number
  State
Gi0/14    SA      4096      0014.4f01.ddd2  28s    0x0    0x3E9  0x4
0x3D

Age of the port in the current state: 692d:17h:49m:29s



--
Dr.Udo Grabowski    Inst.f.Meteorology a.Climate Research IMK-ASF-SAT
www.imk-asf.kit.edu/english/sat.php
KIT - Karlsruhe Institute of Technology            http://www.kit.edu
Postfach 3640,76021 Karlsruhe,Germany  T:(+49)721 608-26026 F:-926026

_______________________________________________
OpenIndiana-discuss mailing list
OpenIndiana-discuss@openindiana.org
http://openindiana.org/mailman/listinfo/openindiana-discuss

Reply via email to