On Tue, 8 Dec 2020 11:00:43 GMT, Johan Vos <j...@openjdk.org> wrote:

> Fix for JDK-8257758
> 
> In case the -PtargetArch=arm64 option is supplied to the gradle build, the
> native components that are part of the JavaFX build will target this platform.

I haven't tested it yet. I made a naming suggestion, but otherwise looks OK.

buildSrc/mac.gradle line 32:

> 30: 
> 31: def TARGET_ARCH = "x86_64"
> 32: if (hasProperty('targetArch')) {

Normally, our external gradle properties are all upper-case, so `TARGET_ARCH` 
might be a better name for the property and `targetArch` a better name for the 
local variable.

buildSrc/mac.gradle line 130:

> 128: 
> 129: if (hasProperty('targetArch')) {
> 130:     commonParams = ["-target", "$TARGET_ARCH-apple-macos-11", 
> commonParams]

Maybe surround the variable with curly braces to make it clearer?

-------------

PR: https://git.openjdk.java.net/jfx/pull/363

Reply via email to