I use OpenLDAP (I'm on Linux Slitaz).
And I found several topics about OM and OpenLDAD, but no solutions
were found...
Perhaps the only way to use OM and OpenLDAP is to modify the sources.

On 29 avr, 14:38, bidab <[email protected]> wrote:
> Hi,
>
> You speak about OpenLDAP's log ? Do you use ActivedDirectory or
> OpenLDAP because it's not the same case...
> I see there is some problems with OpenLdap and I don't know if there
> are resolved.
> Perhaps, you could search a similar problem in olders posts...
>
> Bidab
>
> On Apr 29, 2:22 pm, kurky18 <[email protected]> wrote:
>
> > Thank.
>
> > Actually, I configure the file like this :
>
> > #LDAP URL
> > ldap_conn_url=ldap://127.0.0.1:389
>
> > #Loginname for Authentification on LDAP Server - keep emtpy if not
> > requiered
> > ldap_admin=manager
>
> > #Loginpass for Authentification on LDAP Server - keep emtpy if not
> > requiered
> > ldap_passwd=secret
>
> > #LDAP URL, where ldap_admin can be found
> > ldap_login_base=DC:my-domain,DC:com
>
> > #base to search for userdata(of user, that wants to login
> > ldap_search_base=DC:my-domain,DC:com
>
> > # Fieldnames (can differ between Ldap servers)
> > field_user_principal=UID
>
> > The configuration seems to be correct but there is error=34 (DN
> > syntax). I see the OpenLDAP's log and it connect to LDAP but
> > authenfication fail.
> > And, My version of OM is the ready to use, so i can't modify the
> > source code...
>
> > On 29 avr, 13:43, bidab <[email protected]> wrote:
>
> > > Hi,
>
> > > 1- For LDAP url, it's better to put the IP adress (because of error
> > > DNS for example).
> > > 2- Then for the LDAP_admin, it's the "cn" that is write on your LDAP
> > > config.
> > > 3- LDAP_blogin_base is where your admin is located
> > > 4- LDAP_search_base could limited users able to connect to
> > > OpenMeetings
>
> > > Try this code on eclipse or linux if you ara javac installed.
> > > How known if connection functions ? --> Return the description of user
>
> > > //Created by O. Becherer and little modified
>
> > > import java.util.*;
> > > import javax.naming.*;
> > > import javax.naming.directory.Attribute;
> > > import javax.naming.directory.Attributes;
> > > import javax.naming.directory.DirContext;
> > > import javax.naming.directory.InitialDirContext;
>
> > > public class MakeRoot {
> > >      final static String ldapServerName = "@IP_of_LDAP_server";
> > >      final static String rootdn =
> > > "CN=CN_write_on_LDAP_config,OU=...,OU=...,DC=...,DC=...;
> > >      final static String rootpass = yourPSSWD";
> > >      final static String rootContext =
> > > "OU=...,OU=..,OU=...,DC=...,DC=...";
> > >      public static void main( String[] args ) {// set up environment
> > > to access the server
> > >              Properties env = new Properties();
> > >              env.put
> > > ( Context.INITIAL_CONTEXT_FACTORY,"com.sun.jndi.ldap.LdapCtxFactory" );
> > >                          env.put(Context.PROVIDER_URL, "ldap://"; + 
> > > ldapServerName + "/" );
> > >              env.put( Context.SECURITY_PRINCIPAL, rootdn );
> > >              env.put( Context.SECURITY_CREDENTIALS, rootpass );
> > >              try {// obtain initial directory context using the
> > > environment
> > >                      DirContext ctx = new InitialDirContext( env );
> > >                     // now, create the root context, which is just a
> > > subcontext
> > >                     // of this initial directory context.
> > >                    //ctx.createSubcontext( rootContext );
> > >                      Attributes attributs = ctx.getAttributes(rootdn);
> > >                      Attribute attribut = (Attribute) attributs.get
> > > ("description") ; // on récupère les infos du champs description.
> > >                      System.out.println("Description : " + attribut.get
> > > ());
>
> > >              } catch ( NameAlreadyBoundException nabe ) {
> > >                      System.err.println( rootContext + " has already
> > > been bound!" );
> > >              } catch ( Exception e ) {
> > >                      System.err.println( e );
> > >              }
> > >      }
>
> > > }
>
> > > Bidab
>
> > > On Apr 29, 9:59 am, kurky18 <[email protected]> wrote:
>
> > > > Hi all.
>
> > > > I'm using Red5 0.8 RC2 with OM 0.8 RC2.
>
> > > > Well, I see a lot of post to configure OpenMeetings Authentification
> > > > with LDAP, but I failed all the time.
> > > > My om_ldap.cfg config :
>
> > > > #LDAP URL
> > > > ldap_conn_url=ldap://localhost:389
>
> > > > #Loginname for Authentification on LDAP Server - keep emtpy if not
> > > > requiered
> > > > ldap_admin=cn:manager,dc=my-domain,dc:com
>
> > > > #Loginpass for Authentification on LDAP Server - keep emtpy if not
> > > > requiered
> > > > ldap_passwd=secret
>
> > > > #LDAP URL, where ldap_admin can be found
> > > > ldap_login_base=ou:People,dc:my-domain,dc:com
>
> > > > #base to search for userdata(of user, that wants to login
> > > > ldap_search_base=ou:People,dc:my-domain,dc:com
>
> > > > In ldapmydamin login is "mc=manager,dc=my-domain,dc=com" and pass is
> > > > "secret" (all without quote ==>")
>
> > > > I tried to put ldap_conn_url=ldap://localhost:389/dc=my-
> > > > domain,dc=com , but the split method hate this.
>
> > > > The tree is like this :
>
> > > > dc=my-domain,dc=com
> > > > ---ou=People
> > > > ------cn=name_one
> > > > ------cn=name_two
> > > > ------cn=...
> > > > ------uid=admin       ==>(where dn=manager)
>
> > > > In the error log :
>
> > > > ERROR LdapAthBase.java 3041363 103
> > > > org.openmeetings.app.data.user.Usermanagement [pool-4-thread-16] -
> > > > Authentification on LDAP Server failed : [LDAP: error code 34 -invalid
> > > > dn]
>
> > > > How i can connect to LDAP?
> > > > Thank You for any help.
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"OpenMeetings User" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to 
[email protected]
For more options, visit this group at 
http://groups.google.com/group/openmeetings-user?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to