- **status**: review --> fixed
- **Comment**:

changeset:   7734:1c6b70652a11
user:        Anders Widell <a...@..com>
date:        Tue Jun 21 14:58:44 2016 +0200
summary:     base: Change ncs_task_create() parameter from char* to const char* 
[#1871]

changeset:   7735:f4be100cede0
user:        Anders Widell <a...@..com>
date:        Tue Jun 21 14:58:49 2016 +0200
summary:     rde: Fix cpplint warnings [#1871]

[staging:1c6b70]
[staging:f4be10]




---

** [tickets:#1871] rde: Fix cpplint warnings**

**Status:** fixed
**Milestone:** 5.1.FC
**Created:** Thu Jun 09, 2016 11:29 AM UTC by Anders Widell
**Last Updated:** Thu Jun 09, 2016 02:31 PM UTC
**Owner:** Anders Widell


cpplint.py gives the following warnings in the RDE service:

~~~
osaf/libs/core/include/rda_papi.h:30:  #ifndef header guard has wrong style, 
please use: OSAF_LIBS_CORE_INCLUDE_RDA_PAPI_H_  [build/header_guard] [5]
osaf/libs/core/include/rda_papi.h:141:  #endif line should be "#endif  // 
OSAF_LIBS_CORE_INCLUDE_RDA_PAPI_H_"  [build/header_guard] [5]
osaf/libs/core/include/rda_papi.h:38:  Include the directory when naming .h 
files  [build/include] [4]
Done processing osaf/libs/core/include/rda_papi.h
osaf/libs/agents/infrastructure/rda/rda.h:30:  #ifndef header guard has wrong 
style, please use: OSAF_LIBS_AGENTS_INFRASTRUCTURE_RDA_RDA_H_  
[build/header_guard] [5]
osaf/libs/agents/infrastructure/rda/rda.h:85:  #endif line should be "#endif  
// OSAF_LIBS_AGENTS_INFRASTRUCTURE_RDA_RDA_H_"  [build/header_guard] [5]
osaf/libs/agents/infrastructure/rda/rda.h:37:  Found C system header after C++ 
system header. Should be: rda.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/libs/agents/infrastructure/rda/rda.h:39:  Found C system header after C++ 
system header. Should be: rda.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/libs/agents/infrastructure/rda/rda.h:40:  Found C system header after C++ 
system header. Should be: rda.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/libs/agents/infrastructure/rda/rda.h:41:  Found C system header after C++ 
system header. Should be: rda.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/libs/agents/infrastructure/rda/rda.h:42:  Found C system header after C++ 
system header. Should be: rda.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/libs/agents/infrastructure/rda/rda.h:43:  Found C system header after C++ 
system header. Should be: rda.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/libs/agents/infrastructure/rda/rda.h:45:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda.h:46:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda.h:48:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda.h:49:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda.h:50:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda.h:51:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda.h:52:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda.h:53:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda.h:54:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda.h:55:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda.h:56:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda.h:57:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda.h:58:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda.h:60:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda.h:61:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda.h:61:  "ncssysf_lck.h" already included 
at osaf/libs/agents/infrastructure/rda/rda.h:50  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda.h:62:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda.h:67:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda.h:68:  Include the directory when 
naming .h files  [build/include] [4]
Done processing osaf/libs/agents/infrastructure/rda/rda.h
osaf/libs/agents/infrastructure/rda/rda_papi.cc:35:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda_papi.cc:36:  Found C++ system header 
after other header. Should be: rda_papi.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/libs/agents/infrastructure/rda/rda_papi.cc:37:  Found C++ system header 
after other header. Should be: rda_papi.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/libs/agents/infrastructure/rda/rda_papi.cc:38:  Found C system header 
after other header. Should be: rda_papi.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/libs/agents/infrastructure/rda/rda_papi.cc:39:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda_papi.cc:40:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda_papi.cc:41:  Include the directory when 
naming .h files  [build/include] [4]
osaf/libs/agents/infrastructure/rda/rda_papi.cc:197:  Use int16/int64/etc, 
rather than the C type long  [runtime/int] [4]
osaf/libs/agents/infrastructure/rda/rda_papi.cc:248:  Extra space before )  
[whitespace/parens] [2]
osaf/libs/agents/infrastructure/rda/rda_papi.cc:248:  Using C-style cast.  Use 
const_cast<char * >(...) instead  [readability/casting] [4]
osaf/libs/agents/infrastructure/rda/rda_papi.cc:364:  Never use sprintf. Use 
snprintf instead.  [runtime/printf] [5]
osaf/libs/agents/infrastructure/rda/rda_papi.cc:428:  Never use sprintf. Use 
snprintf instead.  [runtime/printf] [5]
osaf/libs/agents/infrastructure/rda/rda_papi.cc:552:  Never use sprintf. Use 
snprintf instead.  [runtime/printf] [5]
osaf/libs/agents/infrastructure/rda/rda_papi.cc:589:  Never use sprintf. Use 
snprintf instead.  [runtime/printf] [5]
osaf/libs/agents/infrastructure/rda/rda_papi.cc:723:  Almost always, snprintf 
is better than strcpy  [runtime/printf] [4]
Done processing osaf/libs/agents/infrastructure/rda/rda_papi.cc
osaf/services/infrastructure/rde/rde_amf.cc:18:  Include the directory when 
naming .h files  [build/include] [4]
osaf/services/infrastructure/rde/rde_amf.cc:23:  Include the directory when 
naming .h files  [build/include] [4]
osaf/services/infrastructure/rde/rde_amf.cc:24:  Include the directory when 
naming .h files  [build/include] [4]
osaf/services/infrastructure/rde/rde_amf.cc:115:  Using C-style cast.  Use 
reinterpret_cast<char*>(...) instead  [readability/casting] [4]
osaf/services/infrastructure/rde/rde_amf.cc:115:  Almost always, snprintf is 
better than strcpy  [runtime/printf] [4]
osaf/services/infrastructure/rde/rde_amf.cc:124:  Almost always, snprintf is 
better than strcpy  [runtime/printf] [4]
osaf/services/infrastructure/rde/rde_amf.cc:126:  Almost always, snprintf is 
better than strcpy  [runtime/printf] [4]
osaf/services/infrastructure/rde/rde_amf.cc:128:  Using C-style cast.  Use 
reinterpret_cast<char*>(...) instead  [readability/casting] [4]
osaf/services/infrastructure/rde/rde_amf.cc:128:  Almost always, snprintf is 
better than strcpy  [runtime/printf] [4]
osaf/services/infrastructure/rde/rde_amf.cc:129:  Using C-style cast.  Use 
reinterpret_cast<char*>(...) instead  [readability/casting] [4]
osaf/services/infrastructure/rde/rde_amf.cc:178:  Using C-style cast.  Use 
reinterpret_cast<char*>(...) instead  [readability/casting] [4]
osaf/services/infrastructure/rde/rde_amf.cc:178:  Almost always, snprintf is 
better than strcpy  [runtime/printf] [4]
osaf/services/infrastructure/rde/rde_amf.cc:188:  Using C-style cast.  Use 
reinterpret_cast<SaNameT*>(...) instead  [readability/casting] [4]
Done processing osaf/services/infrastructure/rde/rde_amf.cc
osaf/services/infrastructure/rde/rde_rda.cc:40:  Include the directory when 
naming .h files  [build/include] [4]
osaf/services/infrastructure/rde/rde_rda.cc:41:  Include the directory when 
naming .h files  [build/include] [4]
osaf/services/infrastructure/rde/rde_rda.cc:233:  Never use sprintf. Use 
snprintf instead.  [runtime/printf] [5]
osaf/services/infrastructure/rde/rde_rda.cc:263:  Never use sprintf. Use 
snprintf instead.  [runtime/printf] [5]
osaf/services/infrastructure/rde/rde_rda.cc:300:  Never use sprintf. Use 
snprintf instead.  [runtime/printf] [5]
osaf/services/infrastructure/rde/rde_rda.cc:302:  Never use sprintf. Use 
snprintf instead.  [runtime/printf] [5]
osaf/services/infrastructure/rde/rde_rda.cc:343:  Never use sprintf. Use 
snprintf instead.  [runtime/printf] [5]
osaf/services/infrastructure/rde/rde_rda.cc:495:  Line contains only semicolon. 
If this should be an empty statement, use {} instead.  [whitespace/semicolon] 
[5]
osaf/services/infrastructure/rde/rde_rda.cc:499:  Redundant blank line at the 
end of a code block should be deleted.  [whitespace/blank_line] [3]
osaf/services/infrastructure/rde/rde_rda.cc:530:  Never use sprintf. Use 
snprintf instead.  [runtime/printf] [5]
Done processing osaf/services/infrastructure/rde/rde_rda.cc
osaf/services/infrastructure/rde/rde_mds.cc:18:  <thread> is an unapproved 
C++11 header.  [build/c++11] [5]
osaf/services/infrastructure/rde/rde_mds.cc:19:  <chrono> is an unapproved 
C++11 header.  [build/c++11] [5]
osaf/services/infrastructure/rde/rde_mds.cc:20:  Found C system header after 
C++ system header. Should be: rde_mds.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/services/infrastructure/rde/rde_mds.cc:21:  Found C system header after 
C++ system header. Should be: rde_mds.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/services/infrastructure/rde/rde_mds.cc:22:  Found C system header after 
C++ system header. Should be: rde_mds.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/services/infrastructure/rde/rde_mds.cc:24:  Found C system header after 
C++ system header. Should be: rde_mds.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/services/infrastructure/rde/rde_mds.cc:117:  Using C-style cast.  Use 
reinterpret_cast<NCS_IPC_MSG*>(...) instead  [readability/casting] [4]
osaf/services/infrastructure/rde/rde_mds.cc:150:  Using C-style cast.  Use 
reinterpret_cast<NCS_IPC_MSG*>(...) instead  [readability/casting] [4]
osaf/services/infrastructure/rde/rde_mds.cc:209:  Complex multi-line 
/*...*/-style comment found. Lint may give bogus warnings.  Consider replacing 
these with //-style comments, with #if 0...#endif, or with more clearly 
structured multi-line comments.  [readability/multiline_comment] [5]
Done processing osaf/services/infrastructure/rde/rde_mds.cc
osaf/services/infrastructure/rde/rde_main.cc:21:  Found C system header after 
C++ system header. Should be: rde_main.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/services/infrastructure/rde/rde_main.cc:22:  Found C system header after 
C++ system header. Should be: rde_main.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/services/infrastructure/rde/rde_main.cc:25:  Found C system header after 
C++ system header. Should be: rde_main.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/services/infrastructure/rde/rde_main.cc:26:  Found C system header after 
C++ system header. Should be: rde_main.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/services/infrastructure/rde/rde_main.cc:27:  Found C system header after 
C++ system header. Should be: rde_main.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/services/infrastructure/rde/rde_main.cc:28:  Found C system header after 
C++ system header. Should be: rde_main.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/services/infrastructure/rde/rde_main.cc:29:  Found C system header after 
C++ system header. Should be: rde_main.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/services/infrastructure/rde/rde_main.cc:30:  Found C system header after 
C++ system header. Should be: rde_main.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/services/infrastructure/rde/rde_main.cc:32:  Found C system header after 
C++ system header. Should be: rde_main.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/services/infrastructure/rde/rde_main.cc:33:  Found C system header after 
C++ system header. Should be: rde_main.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/services/infrastructure/rde/rde_main.cc:34:  Found C system header after 
C++ system header. Should be: rde_main.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/services/infrastructure/rde/rde_main.cc:35:  Found C system header after 
C++ system header. Should be: rde_main.h, c system, c++ system, other.  
[build/include_order] [4]
osaf/services/infrastructure/rde/rde_main.cc:36:  "nid_api.h" already included 
at osaf/services/infrastructure/rde/rde_main.cc:34  [build/include] [4]
osaf/services/infrastructure/rde/rde_main.cc:38:  Include the directory when 
naming .h files  [build/include] [4]
osaf/services/infrastructure/rde/rde_main.cc:39:  Include the directory when 
naming .h files  [build/include] [4]
osaf/services/infrastructure/rde/rde_main.cc:40:  Include the directory when 
naming .h files  [build/include] [4]
osaf/services/infrastructure/rde/rde_main.cc:41:  Include the directory when 
naming .h files  [build/include] [4]
Done processing osaf/services/infrastructure/rde/rde_main.cc
osaf/services/infrastructure/rde/role.cc:21:  Include the directory when naming 
.h files  [build/include] [4]
osaf/services/infrastructure/rde/role.cc:23:  <chrono> is an unapproved C++11 
header.  [build/c++11] [5]
osaf/services/infrastructure/rde/role.cc:24:  Include the directory when naming 
.h files  [build/include] [4]
osaf/services/infrastructure/rde/role.cc:25:  Include the directory when naming 
.h files  [build/include] [4]
osaf/services/infrastructure/rde/role.cc:26:  Include the directory when naming 
.h files  [build/include] [4]
osaf/services/infrastructure/rde/role.cc:30:  Include the directory when naming 
.h files  [build/include] [4]
osaf/services/infrastructure/rde/role.cc:102:  Else clause should never be on 
same line as else (use 2 lines)  [whitespace/newline] [4]
Done processing osaf/services/infrastructure/rde/role.cc
osaf/services/infrastructure/rde/include/rde_cb.h:18:  #ifndef header guard has 
wrong style, please use: OSAF_SERVICES_INFRASTRUCTURE_RDE_INCLUDE_RDE_CB_H_  
[build/header_guard] [5]
osaf/services/infrastructure/rde/include/rde_cb.h:88:  #endif line should be 
"#endif  // OSAF_SERVICES_INFRASTRUCTURE_RDE_INCLUDE_RDE_CB_H_"  
[build/header_guard] [5]
osaf/services/infrastructure/rde/include/rde_cb.h:24:  Include the directory 
when naming .h files  [build/include] [4]
osaf/services/infrastructure/rde/include/rde_cb.h:25:  Include the directory 
when naming .h files  [build/include] [4]
osaf/services/infrastructure/rde/include/rde_cb.h:26:  Include the directory 
when naming .h files  [build/include] [4]
osaf/services/infrastructure/rde/include/rde_cb.h:27:  Include the directory 
when naming .h files  [build/include] [4]
osaf/services/infrastructure/rde/include/rde_cb.h:28:  Include the directory 
when naming .h files  [build/include] [4]
Done processing osaf/services/infrastructure/rde/include/rde_cb.h
osaf/services/infrastructure/rde/include/rde_rda_common.h:30:  #ifndef header 
guard has wrong style, please use: 
OSAF_SERVICES_INFRASTRUCTURE_RDE_INCLUDE_RDE_RDA_COMMON_H_  
[build/header_guard] [5]
osaf/services/infrastructure/rde/include/rde_rda_common.h:69:  #endif line 
should be "#endif  // 
OSAF_SERVICES_INFRASTRUCTURE_RDE_INCLUDE_RDE_RDA_COMMON_H_"  
[build/header_guard] [5]
Done processing osaf/services/infrastructure/rde/include/rde_rda_common.h
osaf/services/infrastructure/rde/include/role.h:18:  #ifndef header guard has 
wrong style, please use: OSAF_SERVICES_INFRASTRUCTURE_RDE_INCLUDE_ROLE_H_  
[build/header_guard] [5]
osaf/services/infrastructure/rde/include/role.h:59:  #endif line should be 
"#endif  // OSAF_SERVICES_INFRASTRUCTURE_RDE_INCLUDE_ROLE_H_"  
[build/header_guard] [5]
osaf/services/infrastructure/rde/include/role.h:23:  Include the directory when 
naming .h files  [build/include] [4]
osaf/services/infrastructure/rde/include/role.h:24:  Include the directory when 
naming .h files  [build/include] [4]
osaf/services/infrastructure/rde/include/role.h:33:  "public:" should be 
preceded by a blank line  [whitespace/blank_line] [3]
Done processing osaf/services/infrastructure/rde/include/role.h
osaf/services/infrastructure/rde/include/rde_amf.h:32:  #ifndef header guard 
has wrong style, please use: 
OSAF_SERVICES_INFRASTRUCTURE_RDE_INCLUDE_RDE_AMF_H_  [build/header_guard] [5]
osaf/services/infrastructure/rde/include/rde_amf.h:71:  #endif line should be 
"#endif  // OSAF_SERVICES_INFRASTRUCTURE_RDE_INCLUDE_RDE_AMF_H_"  
[build/header_guard] [5]
osaf/services/infrastructure/rde/include/rde_amf.h:43:  Include the directory 
when naming .h files  [build/include] [4]
osaf/services/infrastructure/rde/include/rde_amf.h:52:  Missing spaces around = 
 [whitespace/operators] [4]
osaf/services/infrastructure/rde/include/rde_amf.h:53:  Missing spaces around = 
 [whitespace/operators] [4]
Done processing osaf/services/infrastructure/rde/include/rde_amf.h
osaf/services/infrastructure/rde/include/rde_rda.h:34:  #ifndef header guard 
has wrong style, please use: 
OSAF_SERVICES_INFRASTRUCTURE_RDE_INCLUDE_RDE_RDA_H_  [build/header_guard] [5]
osaf/services/infrastructure/rde/include/rde_rda.h:104:  #endif line should be 
"#endif  // OSAF_SERVICES_INFRASTRUCTURE_RDE_INCLUDE_RDE_RDA_H_"  
[build/header_guard] [5]
osaf/services/infrastructure/rde/include/rde_rda.h:37:  Include the directory 
when naming .h files  [build/include] [4]
Done processing osaf/services/infrastructure/rde/include/rde_rda.h

~~~


---

Sent from sourceforge.net because opensaf-tickets@lists.sourceforge.net is 
subscribed to https://sourceforge.net/p/opensaf/tickets/

To unsubscribe from further messages, a project admin can change settings at 
https://sourceforge.net/p/opensaf/admin/tickets/options.  Or, if this is a 
mailing list, you can unsubscribe from the mailing list.
------------------------------------------------------------------------------
Attend Shape: An AT&T Tech Expo July 15-16. Meet us at AT&T Park in San
Francisco, CA to explore cutting-edge tech and listen to tech luminaries
present their vision of the future. This family event has something for
everyone, including kids. Get more information and register today.
http://sdm.link/attshape
_______________________________________________
Opensaf-tickets mailing list
Opensaf-tickets@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/opensaf-tickets

Reply via email to