Tarasov Viktor wrote:
Hello,

will it be more appropriate to change the SC_FUNC_RETURN (and similar) define
from:
#define SC_FUNC_RETURN(ctx, level, r) { \
...
}

to:
#define SC_FUNC_RETURN(ctx, level, r) do { \
...
} while(0)

this will certainly improve the readability of the source
code as the macros are then threaded similar to functions
(the command ends with a ';').

Cheers,
Nils
_______________________________________________
opensc-devel mailing list
opensc-devel@lists.opensc-project.org
http://www.opensc-project.org/mailman/listinfo/opensc-devel

Reply via email to