Ben Laurie <[EMAIL PROTECTED]> said:
> If everyone thinks it is a terrible idea I'm prepared to undo it. I'll
> fight first, though, coz I think it is a great idea :-)
I, for one, do think it is a terrible idea and I "vote against" these
changes. Marvelous macros are neat and all, but
- They fragment a clean general purpose stack module into dozens of
different function names, making the code harder to read and
understand and harder to debug.
- They probably choke currently supported compilers.
And worst of all
- They break existing apps.
IMHO, STACKs should follow the model of malloc() and free() and operate
on void types.
______________________________________________________________________
OpenSSL Project http://www.openssl.org
Development Mailing List [EMAIL PROTECTED]
Automated List Manager [EMAIL PROTECTED]