There are many place in Swift code where used hard coded values, such
as response statuses (200, 201, 404, ...) which can replaced with
constants HTTP_OK, HTTP_CREATED, HTTP_NOT_FOUND. Also there is widlly
used idiom 200 <= status < 300, that can be replaced as well with
something like this is_success(status). I want add modules for
defining all required constants (Swift, HTTP).

So I think this changes will improve Swift code readability.

PS: this is an initial changes in github
https://github.com/vitoordaz/swift/commit/7163d5df13ceaf8fc7b53ba812fe16bd7dd31131

_______________________________________________
Mailing list: https://launchpad.net/~openstack
Post to     : openstack@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openstack
More help   : https://help.launchpad.net/ListHelp

Reply via email to