#22627: Adhoc Interface problem
----------------------+------------------------
 Reporter:  rolf@…    |      Owner:  developers
     Type:  defect    |     Status:  new
 Priority:  highest   |  Milestone:
Component:  packages  |    Version:  Trunk
 Keywords:            |
----------------------+------------------------
 Hello,

 i have 3 wifi cards on my RB433ah with my DCMA-82 with a Atheros AR5414
 works pretty i have on this wifi device 1 ap and 1 ad-hoc network.

 But with my both R52Hn with Atheros AR9220 chipset doesnt work i cant add
 a adhoc network stand alone or with a ap network its not possible.

 In Luci i can see always the messages "Wireless is disabled or not
 associated"

 Wireless Config:

 config wifi-device 'radio0'
         option type 'mac80211'
         option channel '11'
         option hwmode '11g'
         option path 'pci0000:00/0000:00:14.0'
         option country 'AT'
         option txpower '20'

 config wifi-iface
         option device 'radio0'
         option mode 'ap'
         option encryption 'none'
         option ssid 'innsbruck.freifunk.open2'
         option network 'wlan0'

 config wifi-device 'radio1'
         option type 'mac80211'
         option path 'pci0000:00/0000:00:12.0'
         option channel 'auto'
         option txpower '17'
         option hwmode '11g'
         option country 'AT'

 config wifi-device 'radio2'
         option type 'mac80211'
         option path 'pci0000:00/0000:00:13.0'
         option txpower '17'
         option country 'AT'
         option hwmode '11a'
         option channel 'auto'
         option htmode 'HT20'

 config wifi-iface
         option device 'radio0'
         option encryption 'none'
         option mode 'adhoc'
         option bssid '02:44:CA:FF:EE:EE'
         option mcast_rate '12000'
         option macaddr '4C:5E:0C:88:54:71'
         option network 'wlan0'
         option ssid 'wifimesh-ibk'

 config wifi-iface
         option device 'radio2'
         option mode 'ap'
         option encryption 'none'
         option network 'wlan2'
         option ssid 'innsbruck.freifunk.open4'

 config wifi-iface
         option device 'radio1'
         option mode 'ap'
         option encryption 'none'
         option ssid 'test2'
         option network 'wlan1'

 config wifi-iface
         option device 'radio1'
         option encryption 'none'
         option ssid 'test1'
         option network 'wlan1'
         option mode 'adhoc'
         option bssid '02:44:CA:FF:EE:EE'

 My Network Config
 config interface 'loopback'
         option ifname 'lo'
         option proto 'static'
         option ipaddr '127.0.0.1'
         option netmask '255.0.0.0'

 config globals 'globals'
         option ula_prefix 'fda2:3de3:6ef6::/48'

 config interface 'wan'
         option ifname 'eth0'
         option proto 'dhcp'

 config interface 'wan6'
         option ifname 'eth0'
         option proto 'dhcpv6'

 config rule6 'wan6_lookup'
         option mark '0x01/0x01'
         option lookup '1'

 config route6 'wan6_unreachable'
         option type 'unreachable'
         option table '1'
         option target '::/0'
         option metric '65535'
         option gateway '::'
         option interface 'loopback'

 config interface 'bat0'
         option ifname 'bat0'
         option macaddr '4C:5E:0C:88:54:71'
         option proto 'none'

 config interface 'wlan0'
         option proto 'static'
         option ipaddr '192.168.1.1'
         option netmask '255.255.255.0'
         option ip6assign '64'
         option type 'bridge'

 config interface 'wlan2'
         option proto 'none'

 config interface 'wlan1'
         option proto 'static'
         option ipaddr '192.168.5.1'
         option netmask '255.255.255.0'
         option type 'bridge'
         option _orig_ifname 'wlan1'
         option _orig_bridge 'true'
         option macaddr '4C:5E:0C:88:54:71'

--
Ticket URL: <https://dev.openwrt.org/ticket/22627>
OpenWrt <http://openwrt.org>
Opensource Wireless Router Technology
_______________________________________________
openwrt-tickets mailing list
openwrt-tickets@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-tickets

Reply via email to