Irei fazer o que consta na documentação do Oracle STARTUP MOUNT; ALTER SYSTEM ENABLE RESTRICTED SESSION; ALTER SYSTEM SET JOB_QUEUE_PROCESSES=0; ALTER SYSTEM SET AQ_TM_PROCESSES=0; ALTER DATABASE OPEN; ALTER DATABASE CHARACTER SET new_character_set; SHUTDOWN IMMEDIATE; -- or SHUTDOWN NORMAL; STARTUP;
Vamos ver se vai depois disso... ________________________________ De: Rafael Mendonca <[email protected]> Para: "[email protected]" <[email protected]> Enviadas: Sexta-feira, 3 de Agosto de 2012 17:33 Assunto: Re: [oracle_br] ORA-02372 O character do banco de produção onde foi gerado o expdp é WE8MSWIN1252, o meu é AL32UTF8. Teria como modificar isso? ________________________________ De: Milton Bastos Henriquis Jr. <[email protected]> Para: [email protected] Enviadas: Sexta-feira, 3 de Agosto de 2012 17:28 Assunto: Re: [oracle_br] ORA-02372 ORA-12899: value too large for column - Valor muito grande para a coluna, ou seja, o dado "não cabe" no campo. ORA-02372:data for row: *string**Cause:*A conversion error occurred while loading data into a table. The message shows values for the field in the row that had the conversion error. Vc alterou o character set do banco, e provavelmente tá tentando fazer o impdp de um dump que foi gerado com outro charcter set, não? 2012/8/3 Rafael Mendonca <[email protected]> > ** > > > Além desse erro, aparecem também mais 2 erros > > ORA-02374: conversion error loading table > "MICROMEDICAO"."MOVIMENTO_ROTEIRO_EMPR" > ORA-12899: value too large for column > ora-02372 data for row > > ________________________________ > De: raffaell.ti77 <[email protected]> > Para: [email protected] > Enviadas: Sexta-feira, 3 de Agosto de 2012 17:24 > Assunto: [oracle_br] ORA-02372 > > > > > Pessoal, estou executando um impdp como faço toda semana, e me deparei com > vários e vários erros em vários servidores com o seguinte erro: > > ora-02372 data for row > > A única coisa que mudei, foi que na criação do banco eu mudei o caracter > que antes era DEFAULT e mudei para unicode. > > Alguém pode ajudar? > > Oracle: 11gR2, redhat 5. > > [As partes desta mensagem que não continham texto foram removidas] > > > -- Att, [As partes desta mensagem que não continham texto foram removidas] ------------------------------------ ---------------------------------------------------------- >Atenção! As mensagens do grupo ORACLE_BR são de acesso público e de inteira >responsabilidade de seus remetentes. Acesse: http://www.mail-archive.com/[email protected]/ ---------------------------------------------------------- >Apostilas » Dicas e Exemplos » Função » Mundo Oracle » Package » Procedure » >Scripts » Tutoriais - O GRUPO ORACLE_BR TEM SEU PROPRIO ESPAÇO! VISITE: >http://www.oraclebr.com.br/ ---------------------------------------------------------- Links do Yahoo! Grupos [As partes desta mensagem que não continham texto foram removidas] [As partes desta mensagem que não continham texto foram removidas]
