Hi all,

browsing through the code of Omsosis-Xml, I noticed lines like

"inputStream = new FileInputStream(file);"

both in the run() method of org.openstreetmap.osmosis.xml.v0_6.FastXmlReader 
and org.openstreetmap.osmosis.xml.v0_6.XmlReader. Maybe I'm overlooking things 
but shouldn't that better be

"inputStream = new BufferedInputStream(new FileInputStream(file));"  ?

Background info: A collegue reminded me to always buffer my streams recently, 
so I did. Still he finds that my java jobs on his cluster machine to cause too 
much i/o activity. That's why I had a look at osmosis, which i use in my 
application.

So, should that be changed?

Curt

_______________________________________________
osmosis-dev mailing list
osmosis-dev@openstreetmap.org
http://lists.openstreetmap.org/listinfo/osmosis-dev

Reply via email to