Severity: moderate
Affected versions:
- Apache Tomcat 11.0.0-M1 through 11.0.18
- Apache Tomcat 10.1.0-M7 through 10.1.52
- Apache Tomcat 9.0.83 through 9.0.115
- Apache Tomcat through 8.5.100 unaffected
- Apache Tomcat Native 1.1.23 through 1.1.34
- Apache Tomcat Native 1.2.0 through 1.2.39
- Apache Tomcat Native 1.3.0 through 1.3.6
- Apache Tomcat Native 2.0.0 through 2.0.13
Description:
CLIENT_CERT authentication does not fail as expected for some scenarios
when soft fail is disabled vulnerability in Apache Tomcat, Apache Tomcat
Native.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from
10.1.0-M7 through 10.1.52, from 9.0.83 through 9.0.115; Apache Tomcat
Native: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39, from
1.3.0 through 1.3.6, from 2.0.0 through 2.0.13.
Users are recommended to upgrade to version Tomcat Native 1.3.7 or
2.0.14 and Tomcat 11.0.20, 10.1.53 and 9.0.116, which fix the issue.
Credit:
gregk4sec (https://github.com/gregk4sec) (finder)
References:
https://lists.apache.org/thread/yz5fxmhd2j43wgqykssdo7kltws57jfz
https://tomcat.apache.org/
https://www.cve.org/CVERecord?id=CVE-2026-29145