Severity: moderate
Affected versions:
- Apache Tomcat 11.0.0-M14 through 11.0.25
- Apache Tomcat 10.1.22 through 10.1.59
- Apache Tomcat 9.0.92 through 9.0.121
Description:
CLIENT_CERT authentication does not fail as expected for some scenarios
when soft fail is disabled vulnerability in Apache Tomcat.
This issue affects Apache Tomcat: from 11.0.0-M14 through 11.0.25, from
10.1.22 through 10.1.59, from 9.0.92 through 9.0.121.
Users are recommended to upgrade to version 11.0.26, 10.1.60 or 9.0.122,
which fix the issue.
Credit:
Mike Read (github.com/Michael-JRead) (finder)
References:
https://lists.apache.org/thread/nmkmjp9l53y8h3oc4n8fc0bkw9dv15sk
https://tomcat.apache.org/
https://www.cve.org/CVERecord?id=CVE-2026-86248