Severity: moderate
Affected versions:
- Apache Kafka 2.4.0 before 4.2.2
- Apache Kafka 4.3.0 before 4.3.2
Description:
Apache Kafka Connect has the
/connector-plugins/{connector-type}/config/validate endpoint on its
REST API to validate connector configurations.
Apache Kafka Connect also support Configuration Providers which enable
to hide the values of sensitive configuration and only resolve them at
runtime.
An attacker with access to the validate endpoint can use it to resolve
and return plaintext values via any of the configuration providers
installed on a Connect worker.
Users are recommended to upgrade to version 4.2.2, 4.3.2, 4.4.0 or
above, which fix this issue.
Credit:
Hyunwoo Kim <[email protected]> (reporter)
Sudhanshu Chauhan <[email protected]>, RedHunt Labs (reporter)
Bartłomiej Dmitruk <[email protected]>, Striga (reporter)
Andrew MacPherson <[email protected]> (reporter)
Mickael Maison <[email protected]> (remediation developer)
References:
https://kafka.apache.org/cve-list
https://www.cve.org/CVERecord?id=CVE-2026-116593