> On 20/07/2018 16:56, Ian Stokes wrote:
> > Hi Ben,
> >
> > The following changes since commit
> > 3c921cc2b6b760bd0db73fd629ee9614edc8914c:
> >
> >    build: Add gitattribute file to build-aux (2018-07-19 21:02:33
> > +0300)
> >
> > are available in the git repository at:
> >
> >    https://github.com/istokes/ovs dpdk_merge
> >
> > for you to fetch changes up to 0e0e9e213f13be508d282ffefd7bbe8c680e4fc8:
> >
> >    sparse: Add support for DPDK. (2018-07-20 15:44:45 +0100)
> >
> 
> Hi Ian,
> 
> After some discussions with Darrell around patch 8/14 of the "Support
> multi-segment mbufs​" patchset, I'll be sending a v6 of that series with
> that patch removed.
> 
> Could that be included in this PR (meaning the previously included v5 of
> the series would be dropped entirely), since it still hasn't been merged
> to master?
> 
> Thanks, and sorry for the trouble here.

No problem, it makes more sense for a new pull request, otherwise there would 
be a revert for patch 8. If you send out a v6 with the required patch removed 
and any other changes (which are small I would think) I can review and apply to 
a new pull request.

Ian

> 
> Tiago.
> 
> > ----------------------------------------------------------------
> > Ben Pfaff (4):
> >        netdev-dpdk: Fix incorrect byte order conversion in log message.
> >        netdev-dpdk: Fix sparse complaints.
> >        netdev-dpdk: Use ETH_ADDR_BYTES_ARGS instead of open-coding it.
> >        sparse: Add support for DPDK.
> >
> > Ian Stokes (1):
> >        Docs: Improve OVS DPDK version mapping notice.
> >
> > Mark Kavanagh (4):
> >        netdev-dpdk: fix mbuf sizing
> >        dp-packet: Init specific mbuf fields.
> >        netdev-dpdk: copy large packet to multi-seg. mbufs
> >        netdev-dpdk: support multi-segment jumbo frames
> >
> > Michael Qiu (1):
> >        dp-packet: copy data from multi-seg. DPDK mbuf
> >
> > Tiago Lam (9):
> >        dp-packet: Fix allocated size on DPDK init.
> >        netdev-dpdk: Serialise non-pmds mbufs' alloc/free.
> >        dp-packet: Fix data_len handling multi-seg mbufs.
> >        dp-packet: Handle multi-seg mbufs in helper funcs.
> >        dp-packet: Handle multi-seg mubfs in shift() func.
> >        dp-packet: Handle multi-seg mbufs in resize__().
> >        dpdk-tests: Add uni-tests for multi-seg mbufs.
> >        dpdk-tests: Accept other configs in OVS_DPDK_START
> >        dpdk-tests: End-to-end tests for multi-seg mbufs.
> >
> > Yipeng Wang (1):
> >        dpif-netdev: Add SMC cache after EMC cache
> >
> >   Documentation/howto/dpdk.rst               |    6 +-
> >   Documentation/intro/install/dpdk.rst       |    6 +-
> >   Documentation/topics/dpdk/bridge.rst       |   15 ++
> >   Documentation/topics/dpdk/jumbo-frames.rst |   52 +++++++
> >   Documentation/topics/dpdk/memory.rst       |   36 +++++
> >   Makefile.am                                |    2 +-
> >   NEWS                                       |    3 +
> >   build-aux/initial-tab-whitelist            |    1 +
> >   include/sparse/automake.mk                 |    9 ++
> >   include/sparse/rte_byteorder.h             |  281
> > +++++++++++++++++++++++++++++++++++
> >   include/sparse/rte_esp.h                   |   65 +++++++++
> >   include/sparse/rte_flow.h                  | 1483
> >
> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> +++++++++++++++++++++++++++++++++++++
> >   include/sparse/rte_icmp.h                  |  106 ++++++++++++++
> >   include/sparse/rte_ip.h                    |  490
> > +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> >   include/sparse/rte_sctp.h                  |  103 +++++++++++++
> >   include/sparse/rte_tcp.h                   |  108 ++++++++++++++
> >   include/sparse/rte_udp.h                   |  103 +++++++++++++
> >   include/sparse/xmmintrin.h                 |   24 +++
> >   lib/cmap.c                                 |   74 ++++++++++
> >   lib/cmap.h                                 |   11 ++
> >   lib/dp-packet.c                            |  221
> > ++++++++++++++++++++++++++--
> >   lib/dp-packet.h                            |  214
> > ++++++++++++++++++++++++---
> >   lib/dpdk.c                                 |    8 +
> >   lib/dpif-netdev-perf.h                     |    1 +
> >   lib/dpif-netdev.c                          |  329
> > ++++++++++++++++++++++++++++++++++++-----
> >   lib/netdev-dpdk.c                          |  270
> > +++++++++++++++++++++++++++-------
> >   lib/netdev-dpdk.h                          |    2 +
> >   tests/automake.mk                          |   10 +-
> >   tests/dpdk-packet-mbufs.at                 |    7 +
> >   tests/pmd.at                               |    7 +-
> >   tests/system-dpdk-macros.at                |    6 +-
> >   tests/system-dpdk-testsuite.at             |    1 +
> >   tests/system-dpdk.at                       |   65 +++++++++
> >   tests/test-dpdk-mbufs.c                    |  518
> > +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> >   vswitchd/vswitch.xml                       |   35 +++++
> >   35 files changed, 4532 insertions(+), 140 deletions(-)
> >   create mode 100644 include/sparse/rte_byteorder.h
> >   create mode 100644 include/sparse/rte_esp.h
> >   create mode 100644 include/sparse/rte_flow.h
> >   create mode 100644 include/sparse/rte_icmp.h
> >   create mode 100644 include/sparse/rte_ip.h
> >   create mode 100644 include/sparse/rte_sctp.h
> >   create mode 100644 include/sparse/rte_tcp.h
> >   create mode 100644 include/sparse/rte_udp.h
> >   create mode 100644 include/sparse/xmmintrin.h
> >   create mode 100644 tests/dpdk-packet-mbufs.at
> >   create mode 100644 tests/test-dpdk-mbufs.c
> >
> > Thanks
> > Ian
> > _______________________________________________
> > dev mailing list
> > d...@openvswitch.org
> > https://mail.openvswitch.org/mailman/listinfo/ovs-dev
> >
_______________________________________________
dev mailing list
d...@openvswitch.org
https://mail.openvswitch.org/mailman/listinfo/ovs-dev

Reply via email to