Ilya Maximets <[email protected]> writes: >> 21/04/2019 11:11, Ophir Munk: >>> Thomas - would you like to explain more on the origins of "rte"? >> >> Ian explained (below) the origin quite clearly. >> It has been decided in the early days by Intel. >> >>> From: Ian Stokes >>> > On 4/17/2019 5:34 PM, Ben Pfaff wrote: >>> > > On Wed, Apr 17, 2019 at 11:45:33AM -0400, Aaron Conole wrote: >>> > >> rte comes from dpdk as an acronym for Run Time Environment. Maybe >>> > >> even just dropping the 'rte_' portion? >>> > > >>> > > *That* is what rte stands for? What a ridiculously generic name. >>> > > It's like naming a library Operating System. >> >> Yes I agree that it's ridiculous :) > > The best header is "rte_eal.h". It looks like DPDK tries to abstract from > itself. > >> >> I already proposed to replace rte_ with dpdk_ prefix >> but the vast majority was against a big replacement. >> Would you support such a change? > > I'm not contributing much to dpdk these days, but I'd support such a > change.
I have a longer (and probably useless, but w/e) opinion below. > This would be a big step toward apps that tries to work with DPDK as a library > and not as a run-time environment. > And, probably, right now is the last chance for DPDK do make such a huge API > break. > There was way too much discussions about API stability and I'm afraid that > DPDK > will petrify soon without ability to change anything. + .5 I think it makes sense to do this change at the time DPDK project declares a stronger ABI&API guarantee. "This is the new ossified ABI/API, and we don't break it." It's a strong declaration to users. And API / ABI are really just user interfaces. Compilers, computers, etc. don't "care". Then again, history is littered with crazier ossification in software. After all, we still use CAR,CDR in lisp and I don't think most people know what that's all about either. Heck, supposedly indices start at 0 rather than 1 to correct for yacht handicapping interrupting the compiler[1][2] and it turns out that isn't a terrible thing. "rte_" *is* one character less than "dpdk_" after all. All this to say, I don't think it really truly matters. As seen in the original patch, people now just think "rte == dpdk" and so it's probably a lot of hassle for not as much gain. Anyone who googles "rte_*" upon encountering it in code will find DPDK. And whatever the reason for using "rte_" originally won't matter. So I guess... do whatever you'd like in your existing code. :) OTOH, for code in OvS, I'll continue to advocate against using *rte* because it's new code and *rte* doesn't really mean anything to OvS anyway. At least in the DPDK project, it meant something. 1: https://en.wikipedia.org/wiki/Zero-based_numbering#Origin 2: http://exple.tive.org/blarg/2013/10/22/citation-needed/ >> >>> > This piqued my interest also, with DPDK in the early days it was >>> > targeting bare >>> > metal comms systems, so the original API was LWRTE (LiteWeight Run Time >>> > Environment) which became RTE as it moved on from bare metal, so it seems >>> > more of a legacy convention. >> _______________________________________________ dev mailing list [email protected] https://mail.openvswitch.org/mailman/listinfo/ovs-dev
