On 15 Apr 2021, at 15:25, David Marchand wrote:

On Thu, Apr 15, 2021 at 1:45 PM Flavio Leitner <f...@sysclose.org> wrote:
+COVERAGE_DEFINE(ipv4_check_too_short);
+COVERAGE_DEFINE(ipv4_check_length_error);
+COVERAGE_DEFINE(ipv6_check_too_short);
+COVERAGE_DEFINE(ipv6_check_length_error);

The check keyword is a bit confusing to me, maybe something like
ipv4_pkt_too_short, etc.?

David may have a different idea, but to me this works to pinpoint
the packet failure to ipv*_sanity_check(). Perhaps the name could
be better. However, a generic name that can be used in more places
would make it harder to pinpoint.

Guess you have to do something like grep “COVERAGE_DEFINE(<name>)” anyway to figure out what it does due to lack of documantion on any coverage counter
:)

Perhaps calling the stats like these helps:
miniflow_extract_ipv*_len_error
miniflow_extract_ipv*_too_short

It still requires you to know OVS internals though.

I agree.
Whatever the name, you either know the internals, or you will grep the
documentation or the sources to get the full meaning.
Making life easier for people familiar with OVS is a nice bonus.
So adding flow and/or extract inside the name seems the best proposal so far.

So you will send a new version with Flavio’s name change above? If so, you can add my ack :)

_______________________________________________
dev mailing list
d...@openvswitch.org
https://mail.openvswitch.org/mailman/listinfo/ovs-dev

Reply via email to